How to Prevent Windows from Saving RDP Connection History (remove existing)?

Piyush 1 Reputation point

i want disable Saving RDP Connection History - computer(ip), username, and password...

anyone who want answer please read my question first

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,991 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Anonymous

    Hi, 1. To remove the ability of Windows to save your credentials when you log into a remote computer, click the Start button and enter “gpedit.msc” (without the quotes) in the Search programs and files box. When Windows finds the gpedit.msc file, either press Enter or click the resulting link. Note that this option will not be available on Starter or Home editions of Windows. ![94617-image.png][1] 2. The Local Group Policy Editor dialog box displays. In the tree in the left pane, navigate to the following item: User Configuration | Administrative Templates | Windows Components | Remote Desktop Services 3. Select the Remote Desktop Connection Client item under Remote Desktop Services. In the Setting list on the right, double-click on the Do not allow passwords to be saved setting. Selecting the Do not allow passwords to be saved settings ![94607-image.png][2] 4. On the dialog box that displays, select the Enabled radio button. ![94460-image.png][3] 5. Click OK to close the dialog box for the Do not allow passwords to be saved setting. ![94598-image.png][4] 6. To close the Local Group Policy Editor dialog box, select Exit from the File menu. ![94633-image.png][5] 7. The Allow me to save credentials check box on the Remote Desktop Connection dialog box will not be available. ![94651-image.png][6] If the answer is helpful, please click "Accept Answer" and upvote it. Best regards [1]: /api/attachments/94617-image.png?platform=QnA [2]: /api/attachments/94607-image.png?platform=QnA [3]: /api/attachments/94460-image.png?platform=QnA [4]: /api/attachments/94598-image.png?platform=QnA [5]: /api/attachments/94633-image.png?platform=QnA [6]: /api/attachments/94651-image.png?platform=QnA

    0 comments No comments

  2. Anonymous


    Haven't received your message in a few days, was your issue resolved?

    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as an answer which can help other community members who have the same questions and find the helpful reply quickly.

    Best regards

    0 comments No comments

  3. Anonymous

    Hi, is everything ok?