AslamNagree-5242 avatar image
0 Votes"
AslamNagree-5242 asked karishmatiwari-msft commented

Service Fabric Upgrade Problems

We have an on-premise service Fabric 5 node Cluster spread on 5 separate VMs. There are 5 Upgrade Domains. The current version of Service Fabric is 6.4.637.9590. We are trying to upgrade to 6.5.676.9590 and facing issues in doing so.

When the upgrade is started using the Start-ServiceFabricClusterUpgrade command through the powershell CLI, the entire cluster goes down. Initially I can run the Get-ServiceFabricClusterUpgrade command immediately after the upgrade starts and it comes back with a "In Progress" status. However thereafter the cluster goes down and I am not even able to connect to the cluster to get the upgrade status.

We have tried this twice and both times this has failed and we have had to restore the VMs from previous snapshots.

We have tried upgrading the cluster once with the application running and also without any applications deployed in the cluster and both times we have seen the same behaviour.

Can you please help as we do not want to recreate the cluster from scratch everytime there is a new version released.



· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

We need to troubleshoot in the live environment to understand ans solve this problem.

Raising a support case will be the better option.

Do you have access to create a support ticket for your subscription?

0 Votes 0 ·

Thanks for your reply. A support ticket has now been raised.

1 Vote 1 ·

Please post the resolution here so that it can help others in the community.

0 Votes 0 ·

0 Answers