Unable to Copy and Paste to and from remote desktop connection on some servers.

Akshay 1 Reputation point

Unable to Copy and Paste to and from the remote desktop connections on some servers. None of the file types are working. I tried folder copy, text file copy, word, excel, .exe file copy. none of those work. Interestingly, copy-paste of text to and from works.

Client OS is Windows 10.
Remote Desktop Server OS is Windows server 2016.

Troubleshooting did so far:

  1. Killed rdpclip.exe and tested. No luck
  2. Rebooted the server and the client. No luck
  3. Added rdpclip.exe to exclusions in Antivirus. No luck
  4. Removed Antivirus and tested. No luck.
  5. Tried local login to the remote desktop server instead of domain login. No luck
  6. Verified in the group policy and made sure Do not allow Clipboard redirection and
    Do not allow drive redirection are set to not configured.
  7. Replaced the rdpclip.exe from a working server. No luck.
  8. Compared local security policies (secpol.msc) with a working server and replicated the same settings on the non-working server. Rebooted after that. No luck.
  9. Tried disabling all the Group Policies that are pushed through Domain Controller. No luck.

Any suggestions as to what more we can do to identify and fix the issue?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,991 questions
{count} votes

10 answers

Sort by: Most helpful
  1. yezzie 1 Reputation point

    I tried this with VPN connection that happened last week and it is interrupting the work.

    In my issue, I change disabled in gpedit.msc and task manager > details > rdpclip.exe (not exist). So I tried to run a new task. but still the same.

    0 comments No comments

  2. Boris Tabenkin 1 Reputation point

    I have been struggling with this for days, coming from MAC. The answer was to kill and restart rdpclip.exe, thanks for the hint.

    0 comments No comments

  3. Harvey Deng 1 Reputation point

    I find another solution to this problem. Close microsoft excel and reconnect the remote desktop. That works for me.

    0 comments No comments

  4. CHAUHAN Dipendra OBS/OCB 1 Reputation point

    restarting rdpclip.exe solved my issue

    0 comments No comments

  5. Veerendra Singirtha 0 Reputation points Microsoft Vendor