Azure DevTest with data projects?

Justin Masse 1 Reputation point
2020-06-30T00:36:59.4+00:00

Hello,

I'm trying to use Azure DevTest to deploy an ARM template that I've created that spins up our entire environment. Problem is that the environment is more based around streaming data/analyzing data versus using VMs/etc.

Is there a way to deploy this sort of "data project" using DevTest? I would like to have the ability to spin up/spin down resources in an automated fashion as this service provides in a managed way versus running batch scripts and the like.

For example, my ARM templates are building an Event Hub, Stream Analytics jobs, and a few other SQL servers. I was trying to follow this link: https://learn.microsoft.com/en-us/azure/devtest-labs/devtest-lab-create-environment-from-arm -- but when I connect it to my git and try to click "Add" the ARM templates do not show up under "Choose a base" so I'm not sure what I'm doing wrong or if this is even possible?

Azure DevTest Labs
Azure DevTest Labs
An Azure service that is used for provisioning development and test environments.
262 questions
Azure Event Hubs
Azure Event Hubs
An Azure real-time data ingestion service.
598 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. BhargaviAnnadevara-MSFT 5,466 Reputation points
    2020-07-01T17:49:55.003+00:00

    @JustinMasse-0688,

    Although I haven't tried deploying such an environment yet, I believe Azure DevTest Labs would allow deploying even complex infrastructures using Azure Resource Manager templates. As mentioned in the docs, these environments can contain any Azure resources that Resource Manager templates can create.

    I tried forking the DevTest Labs public GitHub repository to quickly check and reproduce the issue. But I was able to add my repo as a template repository and browse through the templates on the Azure portal under {MyDevTestLab} > Virtual machine bases > Public environments. (Did you try this too?)

    Next, ensure that the PAT created has adequate access via appropriate "read" or "repo" scopes. If that works well, then verify your Azure Resource Manager template folder paths. Note that it is relative to your git clone URI. For example, I configured /Environments as the path for my templates.

    Please check these and let me know what you see so I can troubleshoot the issue further.