Data Factory Salesforce objects not the same as Objects seen in Salesforce URL

Binway 696 Reputation points
2020-07-03T04:14:49.1+00:00

I have created a LinkedService to connect to the company supplied Salesforce URL using the customised url, the supplied user id, password and have acquired the correct security token. This connection tests successfully. It is also the same parameters that I use to log in when I go to the Salesforce website. I then create a new Dataset using the Salesforce data store that allows me to use the newly created Salesforce LinkedService. The issue is that the Object API Names that appear in the picklist are not the same as the objects I see when I log into the Salesforce URL. And if I select an object such as Account and preview the data, I am seeing vastly different fields and data to what I see when i use exactly the same url and login details via the website.
The Salesforce administrator has selected the API Enabled check box in System permissions for my user but I am still seeing different results. Does anyone have advise on where to look to determine what else maybe missing in my salesforce profile to allow data factory to see the correct objects which may also be customised objects that end with __c or if there is something I have to do in the ADF. Other SF connection I have done have usually been very straightforward.
Thanks
Binway

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
10,133 questions
{count} votes

Accepted answer
  1. Binway 696 Reputation points
    2020-07-07T06:37:06.197+00:00

    Thanks Folks for looking at this. I got to do a shared desktop session with their Salesforce Administrator. It was a permissions issue that the Administrator was able to resolve.


0 additional answers

Sort by: Most helpful