VM Will Not Boot - Please insert the external storage media and press OK

Cam Pitches 1 Reputation point
2020-07-07T21:56:15.007+00:00

I have an Azure VM (Standard E2s v3 2 vcpus, 16 GiB memory) that I am able to start but is not accessible via remote desktop. I have enabled boot diagnostics and can see a dialog box with the message "Please insert the external storage media and press OK".

What is causing this and how do I get around this? I thought it might relate to a windows update and potentially running out of disk space. I increased disk size to 256Gb but I am still getting the same error. I restored a back up from two days ago to a new VM and am getting the same error on the restored machine. I will try restoring from an older backup but is there anything else that I can try?

Thanks
Cam

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,572 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Vinicius Deschamps 201 Reputation points
    2020-07-08T18:38:41.66+00:00

    Hi Picthes,

    I have had the same issue but when I tried to encrypt the disk, not resizing and here is how I was able to solve it

    1. Go to your Virtual Machine
    2. Scroll to Support + troubleshooting, and look for Redeploy, then click at **Redeploy - IMPORTANT: Once you click it, note that the VM will be restarted and data on temporary drive will be lost
      11628-redeploy-vm.png
    3. Wait until the VM is redeployed and check again

    If does not work, follow these steps

    1. Go to your Virtual Machine
    2. Scroll to Settings and look for Size, then choose for a different size, and click Resize
      11545-resize-vm.png
    3. Wait until the VM reboots, and check again
    0 comments No comments

  2. Cam Pitches 1 Reputation point
    2020-07-10T05:15:55.707+00:00

    Thanks for taking the time to answer. I tried both of your suggestions and unfortunately neither worked. In the end I restored from an older backup that I had and I was able to restart the machine.

    I'm guessing the error happened as there was minimal disk space on this machine when windows updated. I have since expanded the size of the attached disk in the hope that this prevents this from happening again.


  3. Sahil Mehta 1 Reputation point
    2020-07-13T04:41:07.427+00:00

    I am also facing the same issue and getting an error "Please insert the external storage media and press OK". I tried to increase my disk size but no luck. I cannot restore my VM because I don't have backup.