xcode 10.2 is currently selected in preferences and is currently incompatible

Mrinal Bakshi 1 Reputation point
2021-06-19T15:13:38.227+00:00

I have Mojave 10.14.6 & Xcode 10.2.
When I am trying to build ios app getting error xcode 10.2 is currently selected in preferences and is currently incompatible with the version of Xamarin.iOS being used.

When tried to upgrade the xcode 12.5 getting message "You have macOS 10.14.6. The application requires macOS 11.0 or later."

What may be the work around, please help!!

Xamarin
Xamarin
A Microsoft open-source app platform for building Android and iOS apps with .NET and C#.
5,293 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. JarvanZhang 23,936 Reputation points
    2021-06-21T01:53:40.583+00:00

    Hello @Mrinal Bakshi ,​

    Welcome to our Microsoft Q&A platform!

    Xamarin.iOS 12 requires Xcode 10.2 (or 10.3) and Xcode 10.2 requires a Mac running macOS 10.14.3 (Mojave) or newer. Since Xamarin.iOS 13.16, the latest features and APIs require Xcode 11.4. And Apple Xcode 11.4 requires a Mac running macOS 10.15.2 (Catalina) or newer which is higher than your mac's. To use the lastest Xamarin.iOS, please update the macOS version on your mac to be applicable with the new version Xcode.

    Check the doc: https://learn.microsoft.com/en-us/xamarin/ios/release-notes/14/14.19

    Best Regards,

    Jarvan Zhang


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.