Azure P2S VPN connected but RDP is not working

HASSAN BIN NASIR DAR 306 Reputation points
2021-06-25T12:28:49.387+00:00

Hi

My Azure Point 2 Site VPN with Azure Active directory is successfully connected. But RDP is not working with Private IP address.

The following address space and subnet are configured on my VNet.

Address Space: 10.0.0.0/16
subnet: 10.0.1.0/26

VM IP Address: 10.0.1.4

I am getting this error

109356-remote.png

Azure VPN Gateway
Azure VPN Gateway
An Azure service that enables the connection of on-premises networks to Azure through site-to-site virtual private networks.
1,420 questions
0 comments No comments
{count} votes

7 answers

Sort by: Most helpful
  1. TravisCragg-MSFT 5,681 Reputation points Microsoft Employee
    2021-06-25T22:46:30.187+00:00

    1) Make sure that Network Security Groups (NSGs) allow inbound traffic from your VPN's client address pool (the IP Address that the RDP connection will be coming from). NSGs will sit on the NIC of the VM, or on the Subnet that the VM is in. the 'Networking' tab of the VM will show you active NSGs and their rules.

    If that doesn't work, make sure that the remote computer is accepting RDP connections.


  2. HASSAN BIN NASIR DAR 306 Reputation points
    2021-06-26T00:47:28.307+00:00

    Rule is

    Source: Any
    Source Port ranges: *
    Destination: Any
    Service: RDP
    Destination Port: 3389 (This is Invisible)
    Protocol: TCP (This is Invisible)
    Action: Allow

    This is only one rule with low priority which I created. Rest of rules are default.


  3. Andreas Baumgarten 99,371 Reputation points MVP
    2021-06-26T05:43:29.967+00:00

    Hi @HASSAN BIN NASIR DAR ,

    is there another VM in Azure you are able to connect via RDP using the P2S VPN?
    Just to make sure it's not a problem with your client connected via P2S VPN.

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten

    0 comments No comments

  4. HASSAN BIN NASIR DAR 306 Reputation points
    2021-06-26T06:46:30.693+00:00

    Hi

    I have only one VM.

    Regards

    0 comments No comments

  5. HASSAN BIN NASIR DAR 306 Reputation points
    2021-06-26T07:50:24.93+00:00

    I have these addresses.

    Address Space: 10.0.0.0/16
    subnet: 10.0.1.0/26

    VM IP Address: 10.0.1.4

    Address pool is configured in Virtual network gateway: 172.16.4.0/24

    @SaiKishor-MSFT can you put NSG rule setting here?

    By the way if I have set this rule:

    Source: Any
    Source Port ranges: *
    Destination: Any
    Service: RDP
    Destination Port: 3389 (This is Invisible)
    Protocol: TCP (This is Invisible)
    Action: Allow

    According to this rule rdp should be working.

    I think I will get the same response as I m getting with above rule. But I can try. Please send me rule. Thanks

    Regards