Exchange 2019 CU 9 search not working

Brian Morris 11 Reputation points
2021-06-29T19:46:09.69+00:00

We are experiencing this issue at our company. We just migrated from Exchange 2013 to Exchange 2019 CU9. We use Outlook in online mode. We cannot use Outlook in Cached Mode.

When you do a search in outlook it only returns the past couple of weeks then skips 4 months then returns the rest of the results.

CU 9 did not fix the search issue.

I also upgraded to Outlook 2019 from Outlook 2013 which did not fix the issue.

I tried some suggestions to move the mailbox to another database which did not work.

When you run the powershell command for big funnel everything appears to be fine.

We do not have Software Assurance so Microsoft will not speak to me.

It's funny Microsoft will take your money for a purchase but if their product is broke they will not warranty it.

Microsoft fix this issue. It is still broke.

Provide some warranty support for your product.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,324 questions
{count} votes

1 answer

Sort by: Most helpful
  1. JeffYang-MSFT 6,241 Reputation points
    2021-06-30T06:17:59.623+00:00

    Hi @Brian Morris ,

    According to my experience, there are indeed some users that have similar search issues when using Exchange 2019, but most of them can get their issues fixed by moving the problematic mailbox to another database. I noticed you have already tried the same operation but did not work. Is this "another database" you mentioned another existed database or a complete new-created database? If you have not tried moving problematic mailbox to a complete new-created database, that should worth a shot. Please try to temporarily create a new database and move several problematic mailboxes into it for test, check if the issue would have any difference.

    If the issue still continues, as I know, Exchange Server 2019 CU 10 has released in the past few days, if possible, it is suggested for you to update your Exchange Server to the latest version and see if the issue could be resolved.

    Thanks for you understanding and support again.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.