Windows 10 File and Printer sharing in a secure way

Akira Sekine 26 Reputation points

Hi All

I have a couple of Windows 10 machines and allowing "File and Printer Sharing" in order to retrieve files among them. Recent Windows Updates will automatically disable this functionalities due to the SMB version 1 issues.

I tried to create a GPO policy to overwrite the changes but I believe this is not secure way to do.

I have been looking for a way to keep the security level and still able to access to PCs using UNC path in Windows Explorer.

Please do let me know if there is a way to allow the access without compromising the security?

Thanks in advance

Akira Sekine

Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,507 questions
{count} votes

Accepted answer
  1. Reza-Ameri 16,156 Reputation points

1 additional answer

Sort by: Most helpful
  1. JiayaoZhu 3,901 Reputation points


    Thanks for posting on our forum!

    Firstly, I agree with what @Reza-Ameri suggested, you can operate file share using unc path without enabling SMBv1.

    Secondly, before you use unc path, you need to check if you have left the servers configured only with the nfsv3 version. Some servers are configured to be compatible with nfsv3 and nfsv4, which this compatible setting can sometimes obstruct windows from working well when you accessed with unc paths.

    Thanks for your support! Besides, would you please help me Accept Answer. An accepted blog can be put on top of our forum, so that people who have a similar issue can get access to their solution more quickly. I would really appreciate it if you could support my work.


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments