GET task lists results in 500 from graph explorer

Pierre Larochelle 6 Reputation points
2021-07-03T20:54:21.68+00:00

From the graph explorer, querying the task lists results in a 500, UnknownError. I seem to have the correct permissions.
111546-screen-shot-2021-07-03-at-14539-pm.png
I seem to have the right permissions:
111547-screen-shot-2021-07-03-at-14559-pm.png

And other requests (like to /me) work as expected:
111548-screen-shot-2021-07-03-at-15151-pm.png

I'm using a personal account.

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
10,557 questions
{count} vote

3 answers

Sort by: Most helpful
  1. Pierre Larochelle 6 Reputation points
    2021-07-16T21:49:19.48+00:00

    Any update here? I'm still getting the same error code (500) but a different error message.

    0 comments No comments

  2. Pierre Larochelle 6 Reputation points
    2021-07-16T21:52:17.69+00:00

    Here's the error message. I'm including it as a screen since I can't post the code.115420-screen-shot-2021-07-16-at-25129-pm.png

    0 comments No comments

  3. Damian 1 Reputation point
    2021-10-16T11:53:35.727+00:00

    I'm getting exactly the same error from both my app, and from graph explorer. I have a valid token, and Tasks.Read,Tasks.Read.Shared,Tasks.ReadWrite,Tasks.ReadWrite.Shared has been granted. Identical code works properly for other accounts.

    Doing a GET on https://graph.microsoft.com/v1.0/me/todo/lists

    I'd really appreciate an update from Microsoft on this.

    {
        "error": {
            "code": "UnknownError",
            "message": "... <h2>500 - Internal server error.</h2>  <h3>There is a problem with the resource you are looking for, and it cannot be displayed.</h3> </fieldset></div></div></body></html>",
            "innerError": {
                "date": "2021-10-16T11:42:15",
                "request-id": "471b2445-59be-45e8-a1ab-bdfcebe083b8",
                "client-request-id": "f0fc75cb-89ee-af30-5b5f-b49f68af6897"
            }
        }
    }
    
    0 comments No comments