question

GiovanniFiorini-7006 avatar image
0 Votes"
GiovanniFiorini-7006 asked MarileeTurscak-MSFT answered

Azure Sphere IoT Sample connection to IoT Central Application not Working

Hi,

I followed all the guide in the microsoft docs and in the .txt file in the sample folder to connect my Sphere application to my IoT Central app.

Everything was working fine, but when i run the 'ShowIoTCentralConfig' program, to retrieve the IoTCentral App. informations, i get this message:

Getting your IoT Central applications
You don't appear to have any registered IoT Central applications.

Then the program stops.

But i actually had setup a CentraL application: i verified my tenant to work with the app, i have a device template and even a real device registered.

I tried to logout/login in the local Sphere tool and on the Central web app, but nothing changed.
any idea how to solve this problem?

Thank you.

azure-active-directory
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

MarileeTurscak-MSFT avatar image
0 Votes"
MarileeTurscak-MSFT answered

You may need to register the application under App Registrations.

alt text

https://docs.microsoft.com/en-us/azure/active-directory/develop/quickstart-register-app

This is more related to web apps and less related to Azure AD, so I would suggest moving this post (re-tagging) to that forum.



registerapp.jpg (87.7 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.