question

SajathPS-8248 avatar image
0 Votes"
SajathPS-8248 asked HarshaJK-6782 answered

Black Screen while RDP on Windows-10

Hello,
We are using Windows-10 for Desktop application. Since we hare accessing all the PCs from remote, when we try to connect the PC, Black screen is getting and after sometime Message is popping " Failed to reconnect to your remote session. Please try to reconnect again". Once this message appeared, It wont be connected until PC restarted. Once PC restarted, 2-3 time RDP will be connected, after that again same will appear. We tried basic which seen in google like Disable persistent bitmap cache etc. but issue is still persisting.

remote-desktop-services
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

Do you have any further question? Please feel free to update.

It will be much appreciated and encouraged if you could click "Accept Answer" and upvote the helpful reply.

0 Votes 0 ·
Spruijt-IT-Consultancy avatar image
1 Vote"
Spruijt-IT-Consultancy answered Spruijt-IT-Consultancy edited

I can confirm that "Prevent installation of devices not described by other policy setting", which I changed to "Not Configured" works !!!

But ! there was an issue with de device setup class settings in the GPO System/Device Installation/Device Installation Restrictions: "Allow non-administrators to install drivers for these device setup classes" or "Allow installation of devices using drivers that match these device setup classes"

I hade some default classes defined in there and the Mouse setup class {4d36e96f-e325-11ce-bfc1-08002be10318} was entered with a trailing space :-)

in the Windows\INF\setupapi.dev.log i noticed the following:

      dvi: Class GUID of device changed to: {4d36e96f-e325-11ce-bfc1-08002be10318}.
      ndv: {Core Device Install} 14:23:30.993
      dvi:      {Install Device - TERMINPUT_BUS\UMB\2&2C22BCC9&0&SESSION13MOUSE1} 14:23:31.009
      dvi:           Device Status: 0x01802400 [0x01 - 0xc0000361]
      dvi:           Parent Device: UMB\UMB\1&841921d&0&TERMINPUT_BUS
 !!!  pol:           The device is explicitly restricted by the following policy settings:
 !!!  pol:           [-] Restricted installation of devices not described by policy
 !!!  pol:      {Device installation policy check [TERMINPUT_BUS\UMB\2&2C22BCC9&0&SESSION13MOUSE1] exit(0xe0000248)}
 !!!  dvi:      Installation of device is blocked by policy!
      dvi:      Device Status: 0x01802400 [0x01]
      dvi: {Install Device - exit(0xe0000248)} 14:23:31.040
      dvi: {Core Device Install - exit(0xe0000248)} 14:23:31.056

Once i remove the trailing space in de GPO the logs shows: (after gpupdate)

 : Previously blocked device is now allowed by policy [TERMINPUT_BUS\UMB\2&2C22BCC9&0&SESSION13MOUSE1]
      pol: {Device Removal Initiated by Policy Change [TERMINPUT_BUS\UMB\2&2C22BCC9&0&SESSION13MOUSE1]}

So if you hav eany weird issues with RDP, not connecting, black screen or even disconnects after logon check the device log for device installation issues :-)












5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ElevenYu-MSFT avatar image
0 Votes"
ElevenYu-MSFT answered ElevenYu-MSFT commented

Hi,

Thank you for posting your issue to Q&A forum.

Please kindly try below solution to see if they can help to resolve your problem.

  1. When black screen displays, Press Alt+Ctrl+End to see if task manager will show.

  2. Then click cancel and see if desktop will show

  3. If only Task Manager but no Desktop appears try running Explorer from Task Manager: File > New Task > Explorer.exe

Also, please try to configure below group policies to see if the issue could resolved.

On the client machine:
Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Desktop Connection Client
Turn Off UDP On Client - Enabled

On the remote machine:
Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Desktop Session Host>Remote Session Environment
WDDM graphics display driver for Remote Desktop Connections - Disabled

Thanks,


If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello,
Please find my response: When black screen displays, Press Alt+Ctrl+End to see if task manager will show ...> No Its not showing

Client Computer: Done the setting as per above

Host Computer: There is no such setting in Windows -10

However, I found one setting was enabled in GPO "Prevent installation of devices not described by other policy setting", which I changed to "Not Configured" and problem seems resolved. So I kept under observation.

1 Vote 1 ·

Thanks for your update.

Hope the issue could be totally resolved.

0 Votes 0 ·
HarshaJK-6782 avatar image
1 Vote"
HarshaJK-6782 answered
  1. Set the RDC display options to "Full Screen" (usually the default).

  2. Press "Ctrl + Shift + Esc" to bring up the task manager.

  3. In the task manager app, click File -> Run new task

  4. Type "explorer" and press enter.

After following the above steps you should be able to see the Desktop load completely.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.