question

akhterhussain-3167 avatar image
0 Votes"
akhterhussain-3167 asked ManikandanK-0738 commented

Zkemkeeper assembly adding

I am facing error ,when i am adding assembly of Zkemkeeper,

Retrieving the COM class factory for component with CLSID {00853A19-BD51-419B-9269-2DABE57EB61F} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

I tried and follow all link which provided in different forums ,but issue not resolve. also register assembly using regsvr32.exe,but error is not going.....

dotnet-aspnet-webforms
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I recently faced this issue and fixed by changing "Enable 32-bit Applications" to True in application pool in IIS.

Check this link for step by step instructions.

https://www.youtube.com/watch?v=1T33zQmUrDs

0 Votes 0 ·

1 Answer

YijingSun-MSFT avatar image
0 Votes"
YijingSun-MSFT answered YijingSun-MSFT commented

Hi @akhterhussain-3167 ,
You must register zkemkeeper in every computer that will use your program, not just in the development environment.

To register the zkemkeeper dll in both development and deployment computers, follow the steps provided in the solution of this post: Error when inserting finger print data into database table. When registering in deployment computers, avoid the steps related with the Visual Studio.

You should also take a look to this document, it provides useful information to understand how zkemkeeper works: COM Class Objects and CLSIDs.

Best regards,
Yijing Sun


If the answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our  documentation  to enable e-mail notifications if you want to receive the related email notification for this thread.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

i have registered it in deployment computers ,followed same step as defined in link.but issue still exit.

0 Votes 0 ·

Hi @akhterhussain-3167 ,
Please change your project build properties Platform target from Any CPU to x86 or x64 based on your system and it may fix the issue.
Best regards,
Yijing Sun

0 Votes 0 ·

i have did same thing but still same issue

0 Votes 0 ·
Show more comments