Domain Controller Can't Be Reached

Puppy.Breath 21 Reputation points
2021-08-10T11:00:10.013+00:00

I'm working with two new servers, both have Windows Server 2019 Standard installed. The servers are being added into a work environment that's never had servers before. I installed ADDS and DNS to SERVER-01 then promoted it to the PDC. That seemed to go perfectly. I installed ADDS and DNS on SERVER-02, but then when I attempt to add SERVER-02 to the new domain and promote it to BDC, I get an error message that says, "Server can't be reached."
I can ping SERVER-01 from SERVER-02, and ping SERVER-02 from SERVER-01.
The servers are on the same subnet.
SERVER-01 IP is 10.1.10.51.
SERVER-02 IP is 10.1.10.55.
I've tried turning off the Windows firewall but that doesn't help.
Any thoughts on why I can't add SERVER-02 to the domain that resides on SERVER-01?
Or why I can't promote SERVER-02 to a BDC?

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,491 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
5,962 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 426.2K Reputation points MVP
    2021-08-10T12:46:05.677+00:00

    On SERVER-01 remove the public DNS then do ipconfig /flushdns, ipconfig /registerdns, restart the netlogon service. Domain controller and members must use the static ip address of domain controller for DNS and no others such as router or public DNS

    SERVER-01 also has an IPv6 address, possibly from router's DHCP server. If IPv6 is not configured correctly it will also cause problems. If this is the case I'd turn off the router's IPv6 DHCP function.

    I did not look further at files since above issues are show stoppers. After corrections if problems persist then put up a new set of files to look at.

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments

4 additional answers

Sort by: Most helpful
  1. Dave Patrick 426.2K Reputation points MVP
    2021-08-10T11:48:23.053+00:00

    Please run;

    Dcdiag /v /c /d /e /s:%computername% >C:\dcdiag.log
    repadmin /showrepl >C:\repl.txt
    ipconfig /all > C:\dc1.txt
    ipconfig /all > C:\dc2.txt

    then put unzipped text files up on OneDrive and share a link.

    0 comments No comments

  2. Puppy.Breath 21 Reputation points
    2021-08-10T12:35:49.187+00:00
    0 comments No comments

  3. Puppy.Breath 21 Reputation points
    2021-08-10T13:09:59.543+00:00

    @Dave Patrick , that did the trick!!!!! Thank you, thank you, THANK YOU!!! I removed the public DNS and disabled IPV6, ran the DNS and netlogon commands and then everything just worked!!!

    0 comments No comments

  4. Dave Patrick 426.2K Reputation points MVP
    2021-08-10T13:16:02.307+00:00

    Glad to hear, you're quite welcome.

    0 comments No comments