Stored Procedure not Executing from normal operation in Azure Data Factory but works from "Rerun from activity"

Anonymous
2021-08-11T00:33:16.74+00:00

I am just not sure how to resolve this issue.

I have a pipeline where it executes a stored procedure (after one step called "Copy data").

When I run the Pipeline, the second step where stored procedure has to do the job does not do the job as expected.

There is no issue with the stored procedure because when I run the stored procedure directly from SQL Server management studio, it works.

This is normal operation, but there is no output (inserting data into table) from Stored Procedure even though it says 'Succeeded':
121990-image.png

Bottom option is available in "Activity runs" mode (after job is done):
When I press "Rerun from activity" (on the Stored procedure step), stored procedure does work.

122049-image.png

I am not sure where to test or fix on this issue.

Update 1/21/2022
This is working now as shown:

167266-image.png

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,702 questions
Transact-SQL
Transact-SQL
A Microsoft extension to the ANSI SQL language that includes procedural programming, local variables, and various support functions.
4,561 questions
{count} vote