GetUserSLProfileData Failed from MySite OrganizationView but Org Cart works fine

George Franz 1 Reputation point
2021-08-12T14:56:15.95+00:00

I am working in SharePoint 2013, upgraded from 2010 and migrated all the MySite sites and went through the visual upgrade. After much work, everything works fine but the OrganizationView.aspx page. It gives the Error: The server method 'GetUserSLProfileData' failed..

This does not happen in the 2010 environment.

I have already confirmed that the MySite Application Pool Account, the Distributed Cache Service Account, and the User Profile Service Account all have full access to the User Profile Service. Also the User Profile Service, Proxy, and Sync Service are all up and running just fine. Is there a way to get this page working in Microsoft Edge.

If I cannot figure this out, I am going to have to add JavaScript to hide the SEE MORE link in the Organization Browser web part on all the User Profile pages, but I know that some users will complain that they do not have the OrganizationView.aspx page anymore.

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,844 questions
{count} votes

1 answer

Sort by: Most helpful
  1. George Franz 1 Reputation point
    2024-01-22T13:50:53.8066667+00:00

    After updating to SharePoint 2016 the issue is gone. So this is no longer an issue! Thanks.

    0 comments No comments