suddently WSUS stopped to sync with the below error

haZ 21 Reputation points
2021-09-05T22:21:23.103+00:00

Hey folks , suddently WSUS stopped to sync with the below error :
Sync failed: Unknown: TypeInitializationException: The type initializer for 'Microsoft.UpdateServices.ServerSyncWebServices.ServerSync.ServerSyncProxy' threw an exception. ---> System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible.
anyone faced such issue before ? i tried to remove and re install WSUS with no success . is it as always firewall ?
i can connect normally to DB using management studio , tried to remove all categories and sync with no success . cleaned all obselte updates also .
any other suggestions ?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,568 questions
Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
1,005 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. Adam J. Marshall 9,116 Reputation points
    2021-09-05T22:35:08.08+00:00

    What version of .NET do you have installed?

    0 comments No comments

  2. haZ 21 Reputation points
    2021-09-06T07:04:31.893+00:00

    on site server ? 4.8 and on the SUP 4.7

    0 comments No comments

  3. Adam J. Marshall 9,116 Reputation points
    2021-09-06T14:41:20.247+00:00

    Please update to 4.8 on the SUP. Ensure TLS1.2 is enabled and defaulted

    https://learn.microsoft.com/en-us/mem/configmgr/core/plan-design/security/enable-tls-1-2-client

    0 comments No comments

  4. Pavel yannara Mirochnitchenko 12,411 Reputation points MVP
    2021-09-06T15:27:47.413+00:00

    When you uninstall WSUS, please also remember to remove WSUS site from IIS. Otherwise you will be left all the old crap from previous WSUS instance.


  5. haZ 21 Reputation points
    2021-09-07T18:58:05.917+00:00

    i did all that with no success unfortunately :( still getting the same error

    0 comments No comments