question

rafakomatsu avatar image
0 Votes"
rafakomatsu asked Seiun-7369 answered

in-place eDiscovery & hold - Error 400 Bad Request

Hi guys, I'm having a problem on Exchange Server 2013 CU23.
When clicking on eDiscovery & hold I am getting error "The request failed. The remote server returned an error: (400) Bad Request." and I don't know where else to "fix" this problem.
I have already performed:

  • Windows Update

  • I applied the patch Exchange2013-KB5001779-x64-en

  • Disabled\Enable TLS 1.0 and 1.1

  • I prepared again the Schema and AD

And yet the problem persists.
It is only in this option eDiscovery & hold, in the others you are accessing.

Has anyone caught this error?

office-exchange-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

joyceshen-MSFT avatar image
0 Votes"
joyceshen-MSFT answered

Hi @rafakomatsu

This thread discussed the same issue as yours, please check the solution below: Exchange 2013 e-Discovery not working after disabling TLS 1.0 and 1.1

Add the following registry keys to make WinHTTP and .NET Framework use TLS 1.2
ENABLING TLS 1.2 ON EXCHANGE SERVER 2013 & 2016

WinHTTP:

 1. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
 “DefaultSecureProtocols”:dword:00000a80
 2. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp
 “DefaultSecureProtocols”:dword:00000a80

.NET Framework:

 1. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319
 “SystemDefaultTlsVersions”=dword:00000001
 2. HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319
 “SystemDefaultTlsVersions”=dword:00000001

I used IISCrypto to disable TLS 1.0/1.1 and enable TLS 1.2 on my Exchange server, after that, when I performed an eDiscovery search by EAC or the command "New-MailboxSearch" in EMS, I got a similar error. Finally, I tried to enable TLS 1.2 for WinHTTP and .NET Framework, after rebooting my server, eDiscovery can work without any error in EAC and EMS.

Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

rafakomatsu avatar image
0 Votes"
rafakomatsu answered joyceshen-MSFT commented

Hi joyceshen-msft, I did it as requested, but it still has an error message.

I left only TLS 1.2.

I revalidated my user's permission and I'm in the Compliance Management group.

To get an idea, I climbed a new server and applied this configuration and the latest updates of Windows Server 2012 R2 and Exchange Server 2013 CU23 and nothing.

I don't know what it can be anymore.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @rafakomatsu

Thanks for providing further information above, did you reboot your server after making the changes?

Please also check if there is any application log recorded in event viewer.

0 Votes 0 ·

Hi @rafakomatsu

Is there any update about your issue so far?

0 Votes 0 ·
BenjaminHuang-3751 avatar image
0 Votes"
BenjaminHuang-3751 answered

I too am facing the same issue. Would it have anything to do with exchange hybrid?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

rafakomatsu avatar image
1 Vote"
rafakomatsu answered AbrarJaved-2134 commented

Hello gentlemen, good afternoon.

Microsoft found the problem and it was the HTTP, EWS (Exchange BackEnd), attribute "msExchInternalNLBBypassHostName" that was missing port 444 forwarding.

It should look like this: https://fqdn_server:444/ews/exchange.asmx

In EWS (Default) this attribute is Null.

It worked for me guys.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @rafakomatsu

Thanks for sharing the information! You could "Accept Answer" for your reply to help more users encounter this issue! Have a nice day!

0 Votes 0 ·

Hi Joyceshen,


We already have the EWS backend set to the url u mentioned, but i still get 400 bad request error. Any advise


0 Votes 0 ·
Seiun-7369 avatar image
0 Votes"
Seiun-7369 answered
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.