Teams fails to load on Linux.

Murray Jones 51 Reputation points


I have been using Teams on Linux for online learning for the past few months. Up until this morning, it has been working without issue.

As of this morning, when attempting to open Teams the following issue occurs:

  • White rectangle the size of teams window briefly appears, then vanishes.
  • Several seconds later, the system tray icon appears.
  • Finally, the blue window shown below appears, and continues to do nothing. It's not using any CPU, and I have tried just waiting. Nothing had happened after half an hour.
  • I have tried running teams as the root user for both of the above options, as well as without root permissions.
  • Yes, I've tried restarting the computor :)


The only thing that I can Identify as having changed since Teams stopped working is that I ran an application update (sudo apt update && sudo apt upgrade).

Here's what I have tried so far. None of these have made any difference:

Some stats about my system:

  • I am running Ubuntu 21.10 with the Xfce desktop environment.
  • Kernel is x86_64 Linux 5.13.0-14-generic
  • I am not short on RAM, CPU, or disk space - Teams has run just fine until today.

Here are the logs, as retrieved through the button in the system tray icon.


Teams forms the basis for my year 12 online learning, so it's pretty important that I can get a quick resolution to this.



Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
452 questions
{count} votes

Accepted answer
  1. Rudolf Tomori 401 Reputation points Microsoft Employee

    Thank you for reporting this issue. As already mentioned in the posts here, the problem is related to glibc 2.34 not being compatible with our implementation. While we look into the issue, we suggest you to use teams from the snapstore. You can install and run it this way:

    1. snap install teams
    2. snap run teams

15 additional answers

Sort by: Newest
  1. Adrián López 0 Reputation points


  2. Marco Feltmann 1 Reputation point

    Version 1.5 worked fine for me until about mid of August.
    Now it has the mentioned startup issue again.
    First found it on Arch, now switched to Debian, but still no luck.

    Teams Version:

    1. 5.00.10453 (via apt)

    Debian Version:
    Linux gopher-cern 5.18.0-4-amd64 #1 SMP PREEMPT_DYNAMIC Debian 5.18.16-1 (2022-08-10) x86_64 GNU/Linux

    apt Version:
    apt 2.5.2 (amd64)

    glibc Version:
    (Debian GLIBC 2.34-7) 2.34

    Tried the official Flatpak with same result.
    Also tried the unofficial Flatpak which has another issue complaining about some missing $DISPLAY since I'm in wayland.

    Content of the ~/.config/Microsoft/Microsoft\ Teams/logs/teams-startup.log:

       Error while parsing hooks JSON. Error: "ENOENT: no such file or directory, open '/home/mafe/.config/Microsoft/Microsoft Teams/hooks.json'"  
       (node:40925) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.  
       illegal access  
       (Use `node --trace-uncaught ...` to show where the exception was thrown)  

    According to a colleague of mine latest greatest Ubuntu works well, so it might be some updated component making trouble.

    @Rudolf Tomori Do you have any ideas (besides vendor-lock to an unfree operating system created by some british-something multi millionaire)?

  3. Tomislav 1 Reputation point

    Hi Rudolf, this version works, but dont know if it would work if I have uninstalled libstdc++6 before it.
    Maybe someone else can confirm if this new package works.

  4. Rudolf Tomori 401 Reputation points Microsoft Employee

    Hello, we have released a new version of the package teams-insiders that is compatible with the new glibc. deb rpm Please confirm if it works on your system.