Teams fails to load on Linux.

Murray Jones 51 Reputation points


I have been using Teams on Linux for online learning for the past few months. Up until this morning, it has been working without issue.

As of this morning, when attempting to open Teams the following issue occurs:

  • White rectangle the size of teams window briefly appears, then vanishes.
  • Several seconds later, the system tray icon appears.
  • Finally, the blue window shown below appears, and continues to do nothing. It's not using any CPU, and I have tried just waiting. Nothing had happened after half an hour.
  • I have tried running teams as the root user for both of the above options, as well as without root permissions.
  • Yes, I've tried restarting the computor :)


The only thing that I can Identify as having changed since Teams stopped working is that I ran an application update (sudo apt update && sudo apt upgrade).

Here's what I have tried so far. None of these have made any difference:

Some stats about my system:

  • I am running Ubuntu 21.10 with the Xfce desktop environment.
  • Kernel is x86_64 Linux 5.13.0-14-generic
  • I am not short on RAM, CPU, or disk space - Teams has run just fine until today.

Here are the logs, as retrieved through the button in the system tray icon.


Teams forms the basis for my year 12 online learning, so it's pretty important that I can get a quick resolution to this.



Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
456 questions
{count} votes

Accepted answer
  1. Rudolf Tomori 401 Reputation points Microsoft Employee

    Thank you for reporting this issue. As already mentioned in the posts here, the problem is related to glibc 2.34 not being compatible with our implementation. While we look into the issue, we suggest you to use teams from the snapstore. You can install and run it this way:

    1. snap install teams
    2. snap run teams

15 additional answers

Sort by: Most helpful
  1. Michael N 41 Reputation points

    Edit /usr/bin/teams and modify the line:

    nohup "$TEAMS_PATH" "$@" --disable-namespace-sandbox --disable-setuid-sandbox > "$TEAMS_LOGS/teams-startup.log" 2>&1 &  

    to include the new option --disable-seccomp-filter-sandbox:

    nohup "$TEAMS_PATH" "$@" --disable-seccomp-filter-sandbox --disable-namespace-sandbox --disable-setuid-sandbox > "$TEAMS_LOGS/teams-startup.log" 2>&1 &  

    The latest glibc update broke another layer of sandboxing in the outdated chromium engine that the Teams Preview for Linux uses. Would be nice to have more frequently updated builds ...

    By the way: I had to post this answer in Firefox. I tried posting it in Edge for Linux - with zero extensions loaded! - and the refused to accept the post, thinking a CSRF attack was taking place:


    Not a good Monday in Microsoft-on-Linux land all around, by the looks of things.

    8 people found this answer helpful.

  2. Knevah 21 Reputation points

    Honestly this is why I prefer not to rely on Microsoft products... in fact Microsoft is one of the reasons I use Linux... but not to get too bitchy about it... I installed teams yesterday in preparation for the first meeting of the pandemic that wants to use Teams, and not Zoom, or another VC that doesn't have these kinds of issues... and I have precisely the same issue as described above.

    While I would like to have a proper solution too... I do have at least a temporary solution for you Murray, so I hope you aren't impacted for your online learning.

    In your home folder, inside the hidden folder ".config", teams created 3 folders (why 3, I dread to think)... make sure teams isn't running, delete these three folders and when you start it again, it will ask you to log in as if it had just been installed... and it will work, for 1 session.

    The folders are pretty obvious:-
    ~/.config/Microsoft Teams - Preview

    For anyone else, I have exactly the same symptoms as Murray.... fresh OS install, fresh teams install... works once after install, then after that will not re-load... just opens blank blue box and waits forever.

    1 person found this answer helpful.

  3. Grigory Milev 16 Reputation points

    I have same bug on version: teams-
    Kernel: 5.16.7
    GLibc: glibc-


    1 person found this answer helpful.
    0 comments No comments

  4. Alexander König 6 Reputation points

    For me Teams stopped working yesterday on Arch Linux 5.16.9-246-tkg-bmq
    The teams processes just restartet themselves over and over again. When I deleted the directories "Microsoft" and "Microsoft Teams - Preview" from my .config directory this issue went away and just a white window is now being shown. See screenshot 174894-bildschirmfoto-2022-02-16-09-31-20.png

    Even the web version wont work for me on linux with the latest Vivaldi Browser, on Windows 10 it works....

    Please fix this quickly.

    1 person found this answer helpful.