question

MauricioPV-0943 avatar image
0 Votes"
MauricioPV-0943 asked MichaelHan-MSFT commented

Sharepoint Online Search error with CSOM

Hello,

I'm using CSOM to search documents in Sharepoint Online, some of my searchs returns documents, but another throw this error:

"Microsoft.SharePoint.Client.ServerException: Remote executors failed, local failback not allowed"

Anyone has any ideas?

thanks a lot,
Mauricio.

office-sharepoint-onlinesharepoint-devoffice-sharepoint-server-search-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

MichaelHan-MSFT avatar image
1 Vote"
MichaelHan-MSFT answered MichaelHan-MSFT commented

Hi @MauricioPV-0943,

I cannot reproduce this error on my end.
And per my research, I only find this issue related with this error: https://stackoverflow.com/questions/68894869/sharepoint-unfamiliar-error-on-kw-search-substratesearchexception-remote-execu There someone said, they made it work by adding a filter in the query, maybe you could have a try.

For the reason why this error happens, I would suggest you open a ticket with Microsoft to check more.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi MichaelHan!

thanks for your answer. I already open a ticket 3 days ago and nobody call me yet....

Now I add filters in my search and it did the work, so I assume that the problem is with the amount of documents to return....

In that case I was filtering only by creation date, and for that day the amount of documents was 4000....

thanks,
Mauricio.

0 Votes 0 ·

@MauricioPV-0943,
If my reply helps you, you could accept it as answer :)

0 Votes 0 ·