Windows Server 2022 Cluster Node Suspend "0x8007138f"

Giandomenico Mucci 1 Reputation point
2021-09-17T14:14:06.56+00:00

Windows Server 2022 Creato Cluster S2D 4 Nodi dalla voce Ruoli riesco a spostare le vm tra i nodi senza errore.
Quando sono nella Voce Nodi e voglio svuotare i Ruoli per sospendere il nodo ho il messaggio di errore sotto allegato.

133183-error.png

Operazioni effettuate:
Eliminato Cluster e Pool e ricreato con nuovo nome Cluster S2D

Fino a quando non ho installato lo storage composto da NVME,SSD,HDD la procedura di sospensione dei nodi funziona correttamente.

Saluti

Windows Server Clustering
Windows Server Clustering
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Clustering: The grouping of multiple servers in a way that allows them to appear to be a single unit to client computers on a network. Clustering is a means of increasing network capacity, providing live backup in case one of the servers fails, and improving data security.
969 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Daniel Meyer 26 Reputation points
    2022-02-15T12:51:04.08+00:00

    We have received a reply from Microsoft. The answer would fit that all non-english operating systems are affected.

    With the command "Get-ClusterResource" the cluster resources can be queried.
    In german OS there is one role which is called: "Integrität"
    In english the role is called: "Health"

    Exactly this name (Health) is apparently expected by the GUI. There is a correspondending message also in the cluster logs:

    • WARN [API] s_ApiOpenResourceEx: Resource Health not found, status = 5007

    Microsoft recommends renaming the ClusterResource to "Health" via Powershell.

    4 people found this answer helpful.

  2. Limitless Technology 39,466 Reputation points
    2021-09-20T07:47:46.18+00:00

    Hello,

    Thank you for reaching out.

    I would like to suggest below troubleshooting steps.

    1. Please open Failover Cluster Manager - > Select cluster and right click and run Cluster validation wizard and check if the report having no warnings.
    2. Within the Failover Cluster Manager -> Click on Cluster events to see what is causing the issue during drain roles
    3. Please check Virtual Switch name you are using on the VMs that are getting this error to ensure that all HOSTS in the cluster have the same exact name.
    4. Please check Gateway and preferred DNS settings in All Hosts and they should be same.

    Hope this helps.

    Thank you.


  3. Daniel Meyer 26 Reputation points
    2022-01-06T14:54:23.677+00:00

    Have you ever found a solution on this problem? We have the same error on Win2022 (german) in our cluster.
    Cluster works fine until we activate S2D via powershell. After that, we get the same 0x8007138f error.

    We have already opened a MS-Case, but no solution yet.


  4. Manuel 1 Reputation point
    2022-02-05T20:12:28.787+00:00

    Same error here with new installed Windows Server 2022 Datacenter Hyperconverged 2-Node-Cluster (german language)
    Suspend-ClusterNode with -ForceDrain is working but i also would like to get that fixed.

    I can find no hints in any eventlog pointing to some cluster-role that causes this error.
    Also the -Verbose option for Suspend-ClusterNode gives no hint to a cause.
    Test-Cluster in powershell also shows no problems.

    0 comments No comments

  5. Yoann Montouchet 16 Reputation points
    2022-02-15T13:10:59.357+00:00

    Hi,
    I can confirm it DOES work for me!
    I renamed that cluster resource (named "Intégrité" here in french) to "Health" and now i can suspend my nodes any way i want without error!!!
    Thanks for providing this feedback!
    Here are the commands i entered through powershell :

    find the name of the cluster resource you have to rename :

    PS C:\Windows\system32> Get-ClusterResource  
    
    Name                                                        State   OwnerGroup               ResourceType  
    ----                                                        -----   ----------               ------------  
    ...  
    Intégrité                                                   Online  Groupe SDDC              Health Service  
    ...  
    

    Actual renaming :

    Get-ClusterResource -Name "Intégrité" | %{ $_.Name = "Health" }  
    

    Now try to suspend your nodes, it should work!
    Hopefully they document this somewhere as lots of people are going to have this issue. Suspending through powershell as i did is also a solution...

    Anyway the issue was found, thanks a lot @Daniel Meyer for providing this explanation and solution!