Windows Server 2019 Start Menu and Search Bar

Cipalam Ind. e Com. de Lam. S/A 1 Reputation point
2021-09-21T17:51:02.55+00:00

Hi!

We had a virtual machine that ran Windows server 2012 R2. After upgrading it to Windows server 2019, the Start Menu and the Search Bar will only work when connected as a Local Administrator. If we sign in as any other type of user (be it local non-admin or AD administrator), the Start Menu simply won't show up.

All other services are working fine, but this situation is a nuisance for us since most of the time the access is made through the network Administrator.

We already tried all sort of solutions that we found in Microsoft's KBs, changing Registry keys, reinstalling the Start Menu, uninstalling and reinstalling graphic adapter drivers, made all the changes sugested on this document: https://learn.microsoft.com/pt-br/windows/configuration/start-layout-troubleshoot .

All the tests were made on cloned VMs.

All help will be gladly accepted.

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,595 questions
Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,565 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Anonymous
    2021-09-21T18:03:50.633+00:00

    In-place upgrades can be problematic which you just found out. A better option is to clean install the operating system, patch fully, migrate roles over to it.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  2. cthivierge 4,056 Reputation points
    2021-09-21T18:21:05.907+00:00

    There is several reasons why the start menu is not working

    Try restarting Windows (you may already tried this one actually)

    Sometimes by restarting the "Explorer" process may work
    Open Task Manager from the taskbar (or by pressing CTRL+Shift+ESC). Go in Process pane and locate Windows Explorer. Right click on the process and select "Restart".

    If it's not working, it may be caused by some application packages. I that case, you can run the following command from an Powershell (Run as Admin)
    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    If it's still not working, you can try a system file checker with the following command line from a Powershell (Run as Admin)
    sfc /scannow

    If there is a message after the scan that says "Windows Resource found corrupt files", then you can run the following command
    DISM /Online /Cleanup-Image /RestoreHealth

    If it's still not working, a clean install would be the option

    hth

    0 comments No comments

  3. Limitless Technology 39,506 Reputation points
    2021-09-22T10:26:43.313+00:00

    Hello @Cipalam Ind. e Com. de Lam. S/A ,

    Do check out the below thread, where the solution is discussed in detail.

    https://learn.microsoft.com/en-us/answers/questions/204147/windows-server-2019-rds-start-amp-search-does-not.html

    ----------------------------------------------------------------------------------------------------

    Hope this answers all your queries, if not please do repost back.
    If an Answer is helpful, please click "Accept Answer" and upvote it : )

    0 comments No comments