Upgrade SQL 2012 SP1 express to SP4 express from command prompt fails

Rathod, Shashi 21 Reputation points
2021-09-21T18:37:25.657+00:00

Hi,

We have a project which requires 1500 machines to be upgraded to SQL 2017 from SQL 2012 SP1, for we which we have chosen 2 step upgrade i.e. 2012 SP1 - 2012 SP4 - 2017.

Currently we are trying to finalize on the silent commands which can be used to Upgrade SQL 2012 SP1 to SP4 and then to SQL 2017.

While trying to upgrade 2012 SP1 to SP4 i could observe that the EXE does not respond when executed from command prompt (run as administrator) but works fine when EXE is executed directly with Run As Administrator.

SQL Error Log inside temp folder ends with: Setup closed with exit code: 0x84C40013
Setup Bootstrap Log file only generates Global Rules file which shows result as: Passed

I have tried to execute with & without silent commands but the result is same.

Kindly revert if anyone have faced/solved such scenario.

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
9,856 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. YufeiShao-msft 6,991 Reputation points
    2021-09-22T03:13:44.027+00:00

    Hi @Rathod, Shashi ,

    Please check your error log for more information.
    The error may be related to the .NET framework. .NET 4.0 is a requirement for SQL Server 2012, but .NET framework is not included in the SQL Server Express media, before you install, please check your .NET framework and install.
    Someone is having the sane problem as you because the command is not written correctly, please check that your command. Like using the /Q or /QS must include the /IACCEPTSQLSERVERLICENSETERMS parameter.
    https://learn.microsoft.com/en-us/sql/database-engine/install-windows/install-sql-server-from-the-command-prompt?view=sql-server-ver15


  2. Rathod, Shashi 21 Reputation points
    2021-09-24T08:52:11.75+00:00

    Hi

    I have tried following command,
    "%~dp0SQLEXPR_x64_ENU.EXE" /Q /IACCEPTSQLSERVERLICENSETERMS /Action=Patch /INSTANCENAME=MSSQLSERVER /SkipInstallerRunCheck /SkipRules=AclPermissionsFacet

    /SkipInstallerRunCheck: Required for SQL 2012 SP2 and later & SQL 2014
    /SkipRules=AclPermissionsFacet: Rule was throwing error

    which was successful first time but later when i tried on another machine i could see below attached error,

    Error Info:
    Inner exception type: System.IO.DirectoryNotFoundException
    Message: Could not find a part of the path 'C:\Program Files\Microsoft SQL Server\110\Setup Bootstrap\Log\20210924_140805**MSSQLSERVER**\Datastore'.

    The bold part in missing from the log folder (refer attached image).135001-image.png