Windows Enterprise 21H1 Deployment - Path not found

Andy Harris 121 Reputation points
2021-09-22T15:45:46.487+00:00

I'm having issues deploying Windows Enterprise 21H1 using MDT, running build version 8456 and ADK version 2004. Windows Enterprise LTSC is deploying correctly.
I had to apply the fix described in the below link to allow the LTSC deployment to work following the ADK upgrade to 2004.
https://support.microsoft.com/en-us/topic/windows-10-deployments-fail-with-microsoft-deployment-toolkit-on-computers-with-bios-type-firmware-70557b0b-6be3-81d2-556f-b313e29e2cb7

The error occurs during the Inject Drivers phase of the process, due to a path not found. I've included a snapshot of the BDD log below:

<![LOG[Found a driver for PCI\VEN_8086&DEV_8C31&REV_05: {7db6f5d8-df0e-48bb-9744-31654f2e9258} from \UTILS\DeploymentShare$\Out-of-box Drivers\USB\iusb3hub_4.0.2.42_C9BCB546A50FC28A6183803CBBCA26AA09AED4EAAEB61EF5C74DA5374831B613\iusb3xhc.inf]LOG]!><time="16:09:23.000+000" date="09-22-2021" component="ZTIDrivers" context="" type="1" thread="" file="ZTIDrivers">
<![LOG[ZTI ERROR - Unhandled error returned by ZTIDrivers: Path not found (76)]LOG]!><time="16:09:23.000+000" date="09-22-2021" component="ZTIDrivers" context="" type="3" thread="" file="ZTIDrivers">
<![LOG[Command completed, return code = -2147467259]LOG]!><time="16:09:23.000+000" date="09-22-2021" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
<![LOG[Litetouch deployment failed, Return Code = -2147467259 0x80004005]LOG]!><time="16:09:23.000+000" date="09-22-2021" component="LiteTouch" context="" type="3" thread="" file="LiteTouch">
<![LOG[For more information, consult the task sequencer log ...\SMSTS.LOG.]LOG]!><time="16:09:23.000+000" date="09-22-2021" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">

I would be grateful for any assistance with resolving this issue.

Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
854 questions
0 comments No comments
{count} votes

Accepted answer
  1. Andy Harris 121 Reputation points
    2021-09-24T08:59:39.53+00:00

    Thanks you for your reply. I think the issue is related to old drivers, so not a real concern.

    I've actually managed to resolve my issue with deploying Enterprise 21H1 by creating a new task sequence, not really sure how it's working as the new task sequence was created the same way as the old. One on the mysteries of MDT!

    1 person found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. AllenLiu-MSFT 42,901 Reputation points Microsoft Vendor
    2021-09-23T08:01:35.037+00:00

    Hi, @Andy Harris
    Thank you for posting in Microsoft Q&A forum.

    Can you validate that this file is present on your Deployment Share:
    \UTILS\DeploymentShare$\Out-of-box Drivers\USB\iusb3hub_4.0.2.42_C9BCB546A50FC28A6183803CBBCA26AA09AED4EAAEB61EF5C74DA5374831B613\iusb3xhc.inf
    If so, try to recreate the share with the same files to see if it helps.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Andy Harris 121 Reputation points
    2021-09-23T08:42:42.007+00:00

    Thank you for the response.

    I checked that the file exists in the Deployment Share, ran a complete regeneration of the Deployment Share in Deployment Workbench , updated the Boot Image in WDS, restarted the WDS service and re-tried a deployment of Enterprise 21H1. The same error occurred in the Inject Drivers phase.

    During the re-generation, there were a number of driver related errors (see example below).

    Installing 1 of 1 - E:\DeploymentShare\Out-of-box Drivers\Net\net8187b_62.1182.0331.2010_B046BD4F8C88E09577AB8151633F255E7A1D5016FDC2B25D4109109C211BE2B3\net8187Se.inf:
    INFO: DISM has skipped driver signature check because the version of running OS and that of target OS do not match.
    Error - An error occurred. The driver package could not be installed.
    For more information, check for log files in the <windir>\inf folder of the target image.

    Error: 2

    The system cannot find the file specified.

    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log