Deploying an azure windows VM with ARM template by setting the EnableAutomaticUpdates to false

POLINENI Kiran 1 Reputation point
2021-09-27T11:39:32.543+00:00

I am deploying an azure VM with ARM template by setting the EnableAutomaticUpdates to false. VM got deployed successfully but the automatic updates are enabled in the VM.

ARM template code used:

"type": "Microsoft.Compute/virtualMachines",
"apiVersion": "2021-03-01",
"name": "[parameters('vmName')]",
"location": "[parameters('location')]",
"properties": {
"hardwareProfile": {
"vmSize": "[parameters('vmSize')]"
},
"osProfile": {
"computerName": "[parameters('vmName')]",
"adminUsername": "[parameters('adminUsername')]",
"adminPassword": "[parameters('adminPassword')]",
"windowsConfiguration": {
"provisionVMAgent": true,
"enableAutomaticUpdates": false
}

135488-image.png

In ARM template even though we set the enableautomaticupdates to false but still enables the option. WHat need to be corrected to disable the automatic updates.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,594 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,496 Reputation points
    2021-09-28T18:17:00.273+00:00

    Hello @POLINENI Kiran ,

    You can try manually turning it off by,

    start>Settings>Control Panel>System

    From the Automatic Updates, tab Select Turn off Automatic Updates. then apply the settings

    Do Check out the below link to get to know more about Microsoft.Compute virtualMachines,

    https://learn.microsoft.com/en-us/azure/templates/microsoft.compute/virtualmachines?tabs=bicep

    -------------------------------------------------------------------------------------------------------------

    Hope this answers all your queries, if not please do repost back.
    If an Answer is helpful, please click "Accept Answer" and upvote it : )

    0 comments No comments