App Service extension for Azure Arc Kubernetes always fails to install

Ben 31 Reputation points

I'm unable to get the App Service extension to install so I can test running an App Service in an Azure Arc Kubernetes. I've tried following the article here and I've tried both an AKS cluster and local cluster via Docker. The app service extension always says "Failed" for the "Install State" with the error below.

"Error: {failed to install chart from path [] for release [appservice-ext]: err [release appservice-ext failed, and has been uninstalled due to atomic being set: timed out waiting for the condition]} occurred while doing the operation : {Installing the extension} on the config"

Anyone managed to get this working? I've created every resource in "East US" since it's in preview.



Azure Kubernetes Service (AKS)
Azure Kubernetes Service (AKS)
An Azure service that provides serverless Kubernetes, an integrated continuous integration and continuous delivery experience, and enterprise-grade security and governance.
1,333 questions
0 comments No comments
{count} vote

Accepted answer
  1. AndrewW-MSFT 81 Reputation points Microsoft Employee

    Hi @Ben ,
    could you share the output of the services list from your cluster(s) please?

    i.e. run kubectl get services -n appservice-ns


    kubectl get services --all-namespaces

    I'm suspecting the LoadBalancer services for the envoy endpoint has not successfully bound to an IP.



    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Ben 31 Reputation points

    Hi Andrew,

    I ran your commands as you can see in the first screenshot and it said Pending against Envoy. I checked my Public IP and I had accidentally created it in AU East, so I created another one in East US and the App Service Extension has now installed correctly. I'll now do some testing to see if I can use it. Thanks for your help :)

    Don't suppose you'd know why I can't use the Public IP if it's in AU east...maybe firewalls/cross region restrictions or just because it's in preview? Be handy to know as it might be the reason I couldn't use my local AKS as I'm in New Zealand.

    Public IP in AU

    Pubic IP in East US



    1 person found this answer helpful.