Xamarin not working under Visual Studio 2019 edition 16.11.3

Nassim Hasbani 1 Reputation point
2021-10-03T03:50:17.237+00:00

i have an App developed under xamarin. when i installed VS 2019 updates and edition 16.11.3 is downloaded i could no longer generate an APK or AAB file.
i keep on getting the message "no androidmanifest.xml found"
and the Archive Option under Build no longer exist, not even when i right click the Android project.

i tried all the options:

  1. Click ok the option " Click here to add one"
  2. Build the App, close the properties window and open it again
  3. Repair Visual Studion
  4. uninstall Visual Studio and reinstalling it again

all with no luck. I have been stuck for a week like this. please can you advise on how to solve that issue

Regards,
Nassim Hasbani

Xamarin
Xamarin
A Microsoft open-source app platform for building Android and iOS apps with .NET and C#.
4,809 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Wenyan Zhang (Shanghai Wicresoft Co,.Ltd.) 15,581 Reputation points Microsoft Employee
    2021-10-04T07:03:24.167+00:00

    Hello,
    Welcome to our Microsoft Q&A platform!

    You could try to clear obj and bin folders, make sure Xamarin.forms is the latest version, check the Android SDK, and create new projects to check if if all new projects have this issue. If this issue still exist, you coud report it to Visual Studio. For more information , you can refer to

    https://stackoverflow.com/questions/16590629/error-dump-failed-because-no-androidmanifest-xml-found
    https://stackoverflow.com/questions/45021965/could-not-load-file-or-assembly-netstandard-version-2-0-0-0-reference/45886961#45886961

    Best Regards,
    Wenyan Zhang


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. Nassim Hasbani 1 Reputation point
    2021-10-15T09:25:40.507+00:00

    the above solution did not work.
    when i removed Visual studio, restarted the system and reinstalled Visual Studio, the problem was still there
    I have to format my system and reinstall visual studio in order to work.
    it seems there was an issue windows 10 upgrade.
    Now all is working fine again.
    Thank you
    Nassim