Need Advice: Exchange Hybrid - User Outlook Client not redirect to Exchange Online after Migration

Yang Yu 126 Reputation points
2021-10-04T04:40:12.677+00:00

Hi,

Working on Exchange 2013 Hybrid Migration. End user outlook can't connect to Exchange Online, showing disconnected. Click the send/receive and it shows cannot find the object. Also having credential prompt keeps popping up and asking for password and not go away.

Run the Test AutoConfiguration and it is succeeded. If I create a new profile, new profile and above "broken profile" both working. I think the Microsoft Online login page was flied out and gone away (Seamless SSO is in place) made the trick.

For some reason, the Outlook is not able to redirect to Exchange Online after user has been migrated from on-prem to online. Didn't see the MS login page at all.

Any advice will be highly appreciated.

Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,998 questions
0 comments No comments
{count} votes

Accepted answer
  1. Yang Yu 126 Reputation points
    2021-10-07T07:25:21.95+00:00

    End up it was one of the conditional access policies which we used to block legacy authentication causing the problem.
    We found the access block in the sign in log. It is odd as I had the same policy in another client and didn’t have this problem when doing hybrid migration.


2 additional answers

Sort by: Most helpful
  1. Amit Singh 4,956 Reputation points
    2021-10-07T07:19:41.53+00:00

    This issue occurs when the name of the pre-migration Autodiscover server is cached in your Outlook profile in the registry.

    For more detail check out this article - https://support.microsoft.com/en-us/topic/after-migration-to-office-365-outlook-doesn-t-connect-or-web-services-don-t-work-3d9df009-597b-5d75-460c-4b7c64c833a1

    You can also check this blog for Hybrid Migration – Migrate Exchange Mailboxes to Office 365.

    I hope these articles help you.

    1 person found this answer helpful.

  2. KyleXu-MSFT 26,246 Reputation points
    2021-10-04T07:11:48.803+00:00

    @Yang Yu

    This is expected behavior, after migration, Outlook still connect to the old configuration. Users need to restart Outlook, usually Outlook could switch to the new configuration.

    If Outlook client doesn't switch to the new configuration, we need to recreate the Outlook profile.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.