Error when you open gpedit.msc: Resource $(string.AllowCloudSearch)' referenced in attribute displayName could not be found

Fahrid F 196 Reputation points

I have replaced search.admx files using Windows 10 May 2021 Update (21H1)

When I try open group policy editor I am getting error

Error when you open gpedit.msc: Resource $(string.AllowCloudSearch)' referenced in attribute displayName could not be found
at line 496, column 275

I did not see any error when I replace the file from Windows 10 April 2018 Update (1803) v2

Need your suggestion on how to avoid this warning on Windows 10 May 2021 Update (21H1)

A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
5,041 questions
Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,427 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,571 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Limitless Technology 39,506 Reputation points

    Hello @Fahrid F

    This may be a code issue not yet detected. Same happened in 1803 (v1) back in the day:

    For a deeper troubleshooting in case you doubt your environment would be to rebuild the policy repository

    ** first of all take a backup of whatever is in your shared repository in the DC, for safety

    With the Group Policy management console closed (it always should be closed when updating templates):
    Rename "PolicyDefinitions" in your \Windows\SYSVOL\sysvol\DOMAIN\Policies folder to "PolicyDefinitions-Old"
    Create a new "PolicyDefinitions" folder in the same location
    Copy all the new ADMX/ADML files into their proper places on that DC.
    Open Group Policy management again and see if things are back to normal.

    Hope this helps with your query,

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  2. Fahrid F 196 Reputation points

    I have not taken backup but just replaced the search admx\ adml files of which is older version and it worked.

  3. TAN Handong 0 Reputation points

    I came across this issue today.

    Installing the .msi file from does not help.

    In the end, I solved this by installing the system updates. I don't know which update works, and I just installed all the updates on the Windows Update panel

    0 comments No comments