Strange behavior in Autoruns v14.03

Ellis Dee 1 Reputation point
2021-10-05T12:17:58.157+00:00

Running on Windows 7 Ultimate 64 bit. Autoruns 64 bit.
I know this was not here 2 or 3 months ago. It looks like it might be a bug in Autoruns
because the registry locations appear to be in order.

What I am seeing is the 2 registry locations for DllDirectory and DllDirectory32 become
4 lines in autoruns, and they are shaded yellow for file not found.

DllDirectory File not found C:\Windows\system32\%SystemRoot
DllDirectory File not found C:\Windows\syswow64\%SystemRoot
DllDirectory32 File not found C:\Windows\system32\%SystemRoot
DllDirectory32 File not found C:\Windows\syswow64\%SystemRoot

These correspond to the registry entries at
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs

Where I have what seems to be the correct entries:

DllDirectory REG_EXPAND_SZ %SystemRoot%\system32
DllDirectory32 REG_EXPAND_SZ %SystemRoot%\syswow64

I cannot delete these entries, nor can I uncheck the boxes. About all I can do is jump to the registry locations. The first two lines in Autoruns both jump to the first registry location, and the second two jump to the second registry location. The computer seems to be operating just fine.

137709-2021-10-05-03-57-49-autoruns-sysinternals-wwwsysin.jpg137710-2021-10-05-04-04-34-registry-editor2.jpg

Sysinternals
Sysinternals
Advanced system utilities to manage, troubleshoot, and diagnose Windows and Linux systems and applications.
1,123 questions
0 comments No comments
{count} votes