Share via

Need check a logs of the document inteeligence

Jagan S 0 Reputation points
2026-02-19T13:28:16.34+00:00

Need to know where to check the logs and someone deleted the trained model it is second time it's urgent we need to check

Azure Document Intelligence in Foundry Tools
{count} votes

2 answers

Sort by: Most helpful
  1. Manas Mohanty 14,750 Reputation points Microsoft External Staff Moderator
    2026-02-25T17:58:06.5433333+00:00

    Hi Jagan S

    Old deletion events won't be recorded in diagnostic setting.

    Creation of Diagnostic setting

    We need to create a new diagnostic setting to route telemetry to log analytic workspace.

    While creating new Diagnostic setting

    Please select "Send to log Analytics workspace" on Destination details.

    Category group- Audit, all Logs

    Categories- Audit, Response and Request, Trace logs.

    Note: A log analytics workspace is provisioned normally during resource creation, Please create one if not available.

    On Log analytic workspace

    You can modify and run below query in Log analytic workspace to find IPS address, Caller etc.

    AzureActivity
    | where TimeGenerated > ago(7d)
    | where ResourceProviderValue == "Microsoft.CognitiveServices"
    | where OperationNameValue has_any ("delete", "Delete")
    | project
        TimeGenerated,
        OperationNameValue,
        ActivityStatusValue,
        Caller,
        CallerIpAddress,
        ResourceGroup,
        ResourceId,
        CorrelationId
    | order by TimeGenerated desc
    
    
    
    ResourceManagementPublicAccessLogs
    //| where Category == "PublicAccessLogs"
    | where TimeGenerated > ago(7d)
    //| where ResourceProviderValue == "Microsoft.CognitiveServices"
    | where OperationName has_any ("delete","Delete")
    
    | summarize count() by ObjectIdentifier
    | order by count_ 
    
    

    Reference - https://learn.microsoft.com/en-us/azure/azure-monitor/reference/queries/azureactivity

    You can restrict roles to Cognitive service user (only inference calls work, model creation and deletion would be restricted)

    Thank you.


  2. Q&A Assist
    2026-02-19T13:28:28.17+00:00
    AI generated content. This question contains an answer created with AI from Q&A Assist. Learn more

    To check the logs for the Document Intelligence service, you can use the Get model API to track the status of your trained model. You can query the target model using the target model ID that you obtained during the model generation process. Here’s how you can do it:

    1. Use the following GET request to track the model:
         GET https://<your-resource-endpoint>/documentintelligence/documentModels/{modelId}?api-version=2024-11-30
      
      Replace <your-resource-endpoint> with your actual resource endpoint and {modelId} with the ID of your model.
    2. Include your subscription key in the header:
         Ocp-Apim-Subscription-Key: <your-key>
      

    In the response, you will find information about the model, including its status, which can help you understand what happened to your trained model.

    If you need to check logs related to the operations performed, you can also track the copy progress of operations using the operation ID provided during the copy request.


    References:

    0 comments No comments

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.