Enable Network Level Authentication via GPO, some users RDP to the server get "the remote computer requires Network Level Authentication, which your computer does not support"

Jesse Zhou 106 Reputation points
2021-10-06T01:43:15.54+00:00

Hello everyone,

We would like to enable NLA in the servers, but it seems like some users(Windows 10) can not RDP to the server which is enable NLA.

I check the RDP clients are support NLA.

The server is in the domain but our laptops are managed by Intute, so not in the domain.

I am googling the question, it seems like giving the answer to disable NLA.

For my account is no problem at all.

Does anyone have the same issue before.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,392 questions
{count} votes

Accepted answer
  1. Jesse Zhou 106 Reputation points
    2021-10-08T01:08:32.96+00:00

    Found the reason, the user saved rdp file in the desktop. He has a special configuration for RDP. Re-edit or create a new one, it is working now.

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful