Azure cloudshell - issues with commands

cthivierge 4,056 Reputation points
2021-10-07T03:45:58.123+00:00

Hi,

I am running a az cli command from Azure cloudshell (Powershell or Bash) from my personal Azure tenant and it's working perfectly.

When i want to do the same command from our organization Tenant, i receive an error

I want to show a private endpoint on a Keyvault... the commande line is :

$vaultendpoint = az keyvault private-endpoint-connection show --vault-name myvaultname --name myendpointresource-conn | ConvertFrom-Json

From our organization tenant, here is the error:
ERROR: incorrect usage: [--id ID | --name NAME --vault-name NAME | --name NAME --hsm-name NAME]

What could cause this kind of issue ?

Azure Key Vault
Azure Key Vault
An Azure service that is used to manage and protect cryptographic keys and other secrets used by cloud apps and services.
1,180 questions
Windows Server PowerShell
Windows Server PowerShell
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.PowerShell: A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
5,451 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. cthivierge 4,056 Reputation points
    2021-10-07T15:07:14.313+00:00

    Found the issue this morning...

    This was an issue within a pipeline execution... The Service Principal of the service connection didn't had the Owner permissions on the KeyVault...

    Not very easy to debug with this error message...

    Thanks!