An Azure managed PostgreSQL database service for app development and deployment.
Hi Levent Ozalp,
I have noticed you have raised the support ticket and our team helped to fix the issue., and you have confirmed that you are able to view the metrics from your end.
Regarding the reason as to why you are unable to view the metrics, please refer to the below RCA.
Issue
You were unable to view the server metrics like CPU and disk from your Azure portal.
Root Cause
The disruption was triggered by an unhealthy state in the underlying container. The container encountered a critical failure, which in turn caused this container to become unresponsive and unable to process any requests.
Mitigation
Our engineering team intervened by manually fixed the affected container. This action restored the container to a healthy state and successfully reinstated the availability of the PostgreSQL Metrics.
Next Steps
To mitigate the risk of recurrence, we plan to enhance our monitoring and alerting mechanisms to proactively detect container health anomalies. This will enable faster identification and resolution of such issues, thereby minimizing potential downtime.
Kindly note that no mitigation steps can be performed from your end when container is unhealthy. As Azure Database for PostgreSQL – Flexible Server is a Platform as a Service (PaaS) offering, only our engineering team has the necessary access and privileges to initiate the activity to bring the container back to healthy state.