Realtek Microphone driver not appearing in Sound

FrostyFowl 6 Reputation points
2021-10-08T06:59:03.317+00:00

My laptop is a Dell Inspiron 7590 and the Realtek Driver responsible for the microphone input suddenly disappeared when I switched my microphone to Microphone Array (Intel Smart Sound Technology) microphone (the one built into my laptop) in discord voice and video settings. I have reinstalled the newest Realtek drivers 3 times but that didn't do anything. When I got my headset (a HyperX Cloud Alpha) I had the same problem where there wasn't a Realtek microphone driver in the Recording section. I fixed it by reinstalling the latest Realtek drivers. That solution worked for a few days until I undid it and I'm back to square 1. I have searched the web for an answer but nothing works.

I don't know why I need a tag when I cant find one that fits.

Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
6,029 questions
{count} vote