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APIMS API Disappeared from Portal but still exists

Abigail Kemshall 20 Reputation points
2026-04-08T15:45:37.3566667+00:00

I created a new revision of one of our APIs in API Management Service. We then imported the new version to that revision via Open API json. The import was unusually quick and after checking the endpoints listed the new version had not actually been imported. I had to try re-importing multiple times before it actually showed the new version. Once it worked I saved it and made it current.

When going back to check on it, we found that the API Definintion had disappeared from the portal. The APIs also throw 404. When attempting to import the definition again from scratch, we saw the error 'Cannot create API 'our-api-name' with the same Path 'our-api-path', type 'HTTP' and protocols 'Https' as API 'api-name' unless it's a part of the same version set'.

Running the command az apim api list shows that the API does still exist even though it isn't shown in the portal.

Running az apim api revision list on the API shows that none of them are set to Current.

The revision that was saved and set to current when this issue occured doesn't have a Web Service URL attached even though it was saved with one.

When trying to change a revision to current by using az apim api release create results in a Resource Not Found API not found message. az apim api release list also results in the same error.

The API can be accessed by specifying a revision in the URL.

Any advice on what's going on?

Azure API Management
Azure API Management

An Azure service that provides a hybrid, multi-cloud management platform for APIs.


Answer accepted by question author
  1. Rakesh Mishra 7,785 Reputation points Microsoft External Staff Moderator
    2026-04-08T16:29:17.12+00:00

    Hi Abigail,

    We reached out to backend team regarding the issue and got an update on the issue. Please find the update below.  

    Issue: 

    There are two symptoms of this issue:

    • Users are unable to create an API with a certain name, and they don't see another API with the same name. Creating the API with a certain name fails with a 404.
    • After creating a new release for an existing API, the API and all its revisions disappear from the Azure Portal. Gateway API requests to the API will also start failing with a 404.

    Cause:

    • This issue happens due to a concurrency related race condition bug when two releases of the same API is performed at almost the same time. Due to the race condition, the situation arises where the API still exists in the DB, but it has no revision marked as "Current". Because the API has no current revisions, it does not appear in Azure portal and cannot be used for Gateway API calls. 
    • Another scenario where this could happen is if customer tries to change the current revision of an API while another asynchronous operation is already running on the API. One example of an asynchronous operation is importing an API spec.

    Workaround:

    There is only one possible workaround at the moment. You will need to use PowerShell or REST API to use these workarounds since the API is not visible in the Portal:

    • Delete the API and all its revisions and deploy it again using their CI/CD pipelines.
        DELETE https://management.azure.com/subscriptions/{subscriptionId}/resourceGroups/{resourceGroupName}/providers/Microsoft.ApiManagement/service/{serviceName}/apis/{apiId}?deleteRevisions={deleteRevisions}&api-version=2024-05-01
      

    Prevention:

    • To prevent this from happening, you should ensure there at least a 10-minute delay between the time the import of API and change in the current revision of the API. 
    • Alternately, please create a new revision and then update the API by importing the new definition.  

    Currently, permanent fix for the known issue is in progress. There is no ETA defined at this moment. I will update you once I hear back on this. Meanwhile, we need to use workaround to fix the issue.


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