question

srysolutions-1467 avatar image
0 Votes"
srysolutions-1467 asked KaelYao-MSFT commented

One mail user is consistently showing only in Contacts in O365 portal

We have run below commands to assign a mailbox to user.

Enable-RemoteMailbox –Identity UPN/SamAccountName –PrimarySMTPAddress Email address is removed for privacy –RemoteRoutingAddress Email address is removed for privacy


Set-RemoteMailbox –Identity Email address is removed for privacy –EmailAddresses @{add= Email address is removed for privacy }



But after assigning mailbox ,user is showing up in Contacts lists instead of mailbox Recipient list .

Unable to delete the contact .It gives me error "user is not in valid server write scope" if i try to delete contact of that user

office-exchange-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AndyDavid avatar image
0 Votes"
AndyDavid answered

its probably not syncing correctly.

From on-prem EAC, check to see if the Remote Routing Address is set correctly.
If not, add it there and then set it as the remote routing address in EAC.

should be something like: user@contoso.mail.onmicrosoft.com



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LucasLiu-MSFT avatar image
0 Votes"
LucasLiu-MSFT answered KaelYao-MSFT commented

Hi @srysolutions-1467 ,
Check the mailbox in the EAC of on-premises Exchange. Is the displayed mailbox type Office 365?

1.Agree with what Andy said. First, please check whether the RemoteRoutingAddress you have set is correct, usually the format is "user@Tenant.mail.onmicrosoft.com".

2.Please open Active Directory Users and Computers in DC, and check "Advanced Features" in "View". Then find the AD account associated with the remote mailbox. Check the value of "MSExchMailboxGuid" in the attribute, which is empty by default. If it is not empty, please try to clear the "MSExchMailboxGuid" and "targetAddress" attributes, and run the following command line to force AAD connect to synchronize, and then check whether the remote mailbox appears under "Mailboxes".

 Start-ADSyncSyncCycle



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @srysolutions-1467

I am writing here to confirm with you how thing going now?
If you have any questions or needed further help on this issue, please feel free to post back.
If the issue has been resolved, please accept the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

0 Votes 0 ·