question

wangb24 avatar image
6 Votes"
wangb24 asked gabeyww published

remote desktop to a computer loged in to a passwordless microsoft account

My computer (running windows 10 pro) is login into a passwordless microsoft account.

How can I remote desktop to that computer from remote desktop client when it asks for a password?

Typically I would use my microsoft account password, but now my MS account is passwordless.


Thanks.

remote-desktop-client
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Or, is there a way to set a separate password for a local account that is linked to a MS account.




Currently, when trying to set a password, it prompt:

139615-image.png


0 Votes 0 ·
image.png (300.9 KiB)

This is a weird issue as it is a clear incompatibility between different Microsoft products. I'm quite sure it wouldn't be that hard to implement a capability that triggers a push notification on Authenticator while logging into RDP. Most "solutions" I found online were to disable passwords for RDP altogether, which I think is a huge security breach.

So yeah, no answer here, upvoting the question. Microsoft needs to address this issue

0 Votes 0 ·

203649-image.png




Looks like it's not possible yet if you aren't using Azure or some business way of accessing it:

https://support.microsoft.com/en-us/account-billing/how-to-go-passwordless-with-your-microsoft-account-674ce301-3574-4387-a93d-916751764c43

0 Votes 0 ·
image.png (54.9 KiB)
DSPatrick avatar image
0 Votes"
DSPatrick answered wangb24 commented

You could try setting this one to Disabled

--please don't forget to upvote and Accept as answer if the reply is helpful--

139565-image.png




image.png (718.1 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks for your help.


Unfortunately, this didn't resolve the problem.

After changing this, nothing seemed to happen.

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered PaulinaAcosta-2999 commented

Sounds good, it presents a security risk anyway. Better option is to use a password.

--please don't forget to upvote and Accept as answer if the reply is helpful--



· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just checking if there's any progress or updates?

--please don't forget to upvote and Accept as answer if the reply is helpful--



0 Votes 0 ·

Hi DSPatrick,

It sounds like you are unaware of that you can configure your Microsoft account to have no password. Login attemps triggers an authentication dialog on your Microsoft Authenticator App on your phone. There is no password associated with these accounts.

https://docs.microsoft.com/en-us/azure/active-directory/authentication/howto-authentication-passwordless-phone

/tony

0 Votes 0 ·

Doesnt work with remote desktop connections

0 Votes 0 ·
Wade-7605 avatar image
0 Votes"
Wade-7605 answered MasaakiKoyanagi-8453 commented

I found a solution from youtuber DIY PC HELP: "Windows 11 Remote Desktop Credentials Not Working!".

  1. Open "Credential Manager" (Start, "Credential Manager").

  2. Select "Windows Credentials".

  3. Third section, "Generic Credentials", find "MicrosoftAccount:user=USERID".

  4. Expand, Edit, and then enter your Microsoft Account password. You'll then be able to use this from your RDP client.





· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This method does not work for a passwordless microsoft account.

I tried remote desktop on both windows 11 pro PC and windows 10 pro PC, but failed.

0 Votes 0 ·