question

SusanDodds-3538 avatar image
0 Votes"
SusanDodds-3538 asked DSPatrick commented

Server 2016 Hyper-V Virtual Switch issues

I have 2 server 2016 Hyper-V servers.

Both servers have experienced issues where the Virtual Switches become corrupted after rebooting the Hyper-V host for windows updates.

By corruption, I mean the virtual machines still have some network connectivity but not all. They can see the internet but applications do not work properly, like Exchange, DC replication, SharePoint.

The only way to fix this is to move the VM's to a different virtual switch port, delete the original virtual switch port, re-create that same port, and then move the VM's back to that port.

This has happened on 2 Hyper-V servers with different hardware.

The most recent incidence also caused issues with a backup software program running on one of the Hyper-V hosts until it was rebooted, the host experienced the same symptoms as the VM's, even after the virtual switch was re-created until the reboot.

Is there any way to prevent this?

Thanks.

windows-server-hyper-v
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
0 Votes"
DSPatrick answered

virtual machines still have some network connectivity but not all.

How are you evaluating this?




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SusanDodds-3538 avatar image
0 Votes"
SusanDodds-3538 answered DSPatrick converted comment to answer

They still have internet access, can talk to the hosts, but not other computers over the network. Net based programs like Exchange and SharePoint don't work beyond the host.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
0 Votes"
DSPatrick answered

This sounds like some sort of firewall issue. I'd check to see that all still have the domain network profile and no multi-homed domain controllers. Also check that the domain controller and problem members all have the static ip address of DC listed for DNS and no others such as router or public DNS.

--please don't forget to upvote and Accept as answer if the reply is helpful--








5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SusanDodds-3538 avatar image
0 Votes"
SusanDodds-3538 answered

No changes made in any firewall or DNS.

When changing virtual switch port assignments, the virtual machine doesn't care as long as it has one so the virtual machine network profile doesn't change when changing/deleting/re-creating virtual switch ports on the host.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
0 Votes"
DSPatrick answered DSPatrick commented

No changes made in any firewall or DNS.

Not suggesting this. You'll need to check the next occurrence. I'd also check to see that all still have the domain network profile and no multi-homed domain controllers. Also check that the domain controller and problem members all have the static ip address of DC listed for DNS and no others such as router or public DNS.

--please don't forget to upvote and Accept as answer if the reply is helpful--






· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just checking if there's any progress or updates?

--please don't forget to upvote and Accept as answer if the reply is helpful--



0 Votes 0 ·
SusanDodds-3538 avatar image
0 Votes"
SusanDodds-3538 answered

DNS was still working. DNS entries for each DC was on each server.

This has happened 3 times in 2 years so it might be awhile before it occurs again but I would like to stop it from happening again.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
0 Votes"
DSPatrick answered DSPatrick commented

Sounds good, a corrupt vSwitch seems an unlikely cause. Along that line you might want to check the hardware is supported to run the operating systems in use. A more likely cause is something errant or broken with active directory.

--please don't forget to upvote and Accept as answer if the reply is helpful--



· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just checking if there's any progress or updates?

--please don't forget to upvote and Accept as answer if the reply is helpful--



1 Vote 1 ·