question

ankurdatta-4474 avatar image
0 Votes"
ankurdatta-4474 asked TharaniTharan-4961 commented

public loadbalancer outbound rules showing 0 instance

Hi all,

I am working on 1 solution where we have a development vm need to communicate to internet using public load balancer(SNAT) feature.
I configured everything and when I go to vm and do what's my ip it is not giving me public ip associated with public load balancer.
I checked in outbound rules backend is showing 0 instance whereas I assigned my vm in backend pool of load balancer.

Can you please help in figuring out where is the issue.

azure-load-balancer
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @ankurdatta-4474, Thank you for reaching out. We currently investigating the issue and will reach out to you shortly.

0 Votes 0 ·
ChaitanyaNaykodiMSFT-9638 avatar image
0 Votes"
ChaitanyaNaykodiMSFT-9638 answered ChaitanyaNaykodiMSFT-9638 edited

Hello @ankurdatta-4474, Thank you for your patience and apologies for the delay.

I recreated a similar scenario and I was able to connect to internet via my VM using my Public Load balancer's IP.
141507-image.png

We will go through some configurations below to see if you have set them correctly.

  • Since you are using SNAT to communicate with internet. Can you please confirm if you do not have any NAT gateway configured on your backend subnet?
    141527-image.png

  • Can you please confirm if have the outbound rule set in your Load Balancer? this is outbound rule for the backend pool. Here the LoadBalancerFrontend represents my Loadbalancer Frontend IP, myBackendPool represents my backend pool which consists my VM. If this rule is missing, you can add it via portal or you can follow the documentation here to add it using powershell. Please retry the connectivity from your VM if you had to set this rule.

141429-image.png

  • Can you please confirm if your backend pool is up and running?

141496-image.png

  • When you click on your backend pool above? Do you see your VM listed in it as shown below.

141476-image.png
- In your resource group, can you please validate the NSG associated with your VM and see if any rules are blocking this connectivity?

141526-image.png

  • If does not help can you please check if any firewall on your VM is blocking this connectivity?

  • On Azure Portal on your VM's overview page do you see any Public IP. For me its my Load balancer's public IP . On the networking Tab of the VM in the Topology section you can see how your connectivity is established.

Hope this helps. Please let me know if you have any additional questions, I will be glad to continue with our discussion.



image.png (74.5 KiB)
image.png (37.4 KiB)
image.png (103.1 KiB)
image.png (94.3 KiB)
image.png (129.8 KiB)
image.png (55.2 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MathieuTessier-8040 avatar image
0 Votes"
MathieuTessier-8040 answered TharaniTharan-4961 commented

I had the same issue and it is because the BEP was configured with IP address instead of NIC.

When a backend pool is configured by IP address, it will behave as a Basic Load Balancer with default outbound enabled. For secure by default configuration and applications with demanding outbound needs, configure the backend pool by NIC.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Yes it's worked. Thanks Mat for your help

0 Votes 0 ·