Hyper-V - Server 2022 can't enable TPM on 3 of 4 machines

Chris Danks 96 Reputation points
2021-10-15T16:13:54.283+00:00

Hello,

I have installed Windows Server 2022 on a brand new Dell R640

I created 1 VM with TPM and the OS ISO was Windows 11, this worked fine.

I then created 3 more VMs, when I go to Security > Enable Trusted Platform Module I get this error:

140943-2021-10-15-17-00-58.jpg

I did some googling and found this: https://learn.microsoft.com/en-us/answers/questions/566006/hyper-v-2019-server-enable-tpm.html

but when I tried via Powershell 7.1 I get the same error:

PS C:\Users\Administrator> import-module Hyper-V  
PS C:\Users\Administrator> $owner = Get-HgsGuardian UntrustedGuardian  
PS C:\Users\Administrator> $kp = New-HgsKeyProtector -Owner $owner -AllowUntrustedRoot  
Invoke-CimMethod: C:\Windows\system32\WindowsPowerShell\v1.0\Modules\HgsClient\HgsClient.psm1:380  
Line |  
 380 |          (Invoke-CimMethod -Namespace Root\Microsoft\Windows\Hgs -Clas …  
     |           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~  
     | Certificate has expired, check the time constraints on certificate with thumbprint  
     | '76BB91CC5B0E2B3C75CCCA6F4911DB7D6D8C7ADA'.  

Hoping someone can help me out!

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
1,831 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
8,223 questions
No comments
{count} votes

Accepted answer
  1. Chris Danks 96 Reputation points
    2021-10-15T16:26:32.26+00:00

    I opened MMC and went to cert sotr, found the cert with that ID and the start date is today with 19:36 for the time, right now its 17:26! so this certificate isn't valid for another 2 hours 10 mins... i'll try again tonight and hopefully that'll fix the issue

    No comments

0 additional answers

Sort by: Most helpful