question

JohnnyBarz-0403 avatar image
0 Votes"
JohnnyBarz-0403 asked ElsieLu-MSFT commented

Edit SEO Properties not available for pages - sharepoint

Hi,
I have read the article: https://blog.mastykarz.nl/search-engine-optimization-sharepoint-2013/
and several others.
In this part: "SEO Properties for Publishing Pages"
it is explained how to edit SEO properties of a page, we manage to edit SEO properties for folders in sharepoint but when trying to edit a page the "Edit SEO Properties" is greyed out and we can't use it.
We did a test of creating a wiki page template and then the option is available but when trying for published pages which are under custom templates we cannot edit SEO properties.

Do we need to activate some feature?

Thanks,

sharepoint-devsharepoint-workflow
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm looking into your issue now and I will reply you as soon as possible.

Thanks for your understanding and patience :-)

0 Votes 0 ·

1 Answer

ElsieLu-MSFT avatar image
0 Votes"
ElsieLu-MSFT answered ElsieLu-MSFT commented

Hi @JohnnyBarz-0403 , welcome to Q&A forum!

Per my test, I am able to reproduce your issue in my end:
141830-94.png

The issue is that if your friendly URL equal to the real site’s URLs (which is not bad because it is possible to switch to structural URLs and your links will still work, because http://example.com/test will be automatically resolved to http://example.com/test/pages/default.aspx), then “Edit SEO properties” command will be disabled.

You could try to use the direct URL. For example, the url is http://example.com/test , change it to http://example.com/test/_layouts/15/SEOProperties.aspx?Source=/test/pages/default.aspx&page=1

Reference:
Problem with SEO properties for pages with friendly URLs in Sharepoint 2013
edit-seo-properties-disabled-in-team
Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



94.png (44.5 KiB)
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @ElsieLu-MSFT ,
Thank you for the help though we tried this solution and we receive an error.

We tried this link: https://www.OURSITE.es/_layouts/15/SEOProperties.aspx?Source=/Paginas/default.aspx&page=1
And we receive this: "We are sorry, there was a problem"

142036-image.png



Do you have another solution in mind or maybe we are doing something wrong?

Thanks,

0 Votes 0 ·
image.png (38.8 KiB)

I'm looking into your issue now and I will get back to you ASAP.

1 Vote 1 ·

Hi @JohnnyBarz-0403 ,

Sorry for the delay. As this thread mentioned:

The SEO feature is only for publishing pages, and it is disabled for wiki pages or web part pages.

So if the pages are wiki pages or web part pages, the SEO setting is disabled. This is a default behavior for SEO in SharePoint.

In a publishing page:
143696-104.png


0 Votes 0 ·
104.png (29.7 KiB)

Hi @JohnnyBarz-0403 , is my suggestion helpful? I am willing to hear from you.

0 Votes 0 ·