question

MohamadCHHIMI-7584 avatar image
0 Votes"
MohamadCHHIMI-7584 asked prmanhas-MSFT commented

The "Lease state" for my ARM template Enviroments cash appers as Broken in my Blob service of the storage account created by default with the Devtest lab service.

Hello,
I have created an AZURE devops repository for my AZURE devtest lab services.
My goals are to create custom artifacts and custom ARM template environments.
I succeeded to visualize my custom artifacts but not for environments.
When the AZURE resource manger populate the cash in the Blob service of the storage account in the devtest lab, the environment "Lease state" appear as broken.
You can find a photo of what i mean below.
141747-image.png
How can I debug that ?

Best regards
Mohamad


azure-devtestlabsazure-dtl-arm-enviorments
image.png (39.1 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

prmanhas-MSFT avatar image
0 Votes"
prmanhas-MSFT answered prmanhas-MSFT commented

@MohamadCHHIMI-7584 Apologies for the delay in response and all the inconvenience caused because of the issue.

The user has written templates incorrectly: means they have broken the lease.

You can refer to this to resolve the lease error:

https://azure.microsoft.com/en-us/updates/support-for-blob-storage-lease-management-from-azure-portal/

https://www.reddit.com/r/AZURE/comments/kr5pfr/how_to_fix_storage_container_lease_state/

Hope it helps!!!

Please "Accept as Answer" if it helped so it can help others in community looking for help on similar topics

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello,

Thank you for your answer, but i used an ARM template form the AZURE GitHub repository, for example the "WebApp-MySQL" code.
It should work .

0 Votes 0 ·