DerekO-9513 avatar image
0 Votes"
DerekO-9513 asked

Can't access Microphone through RDP when MIC is directly connected to remote system

I use RDP to connect to a number of headless (no console) Windows 10 Client systems.

Trying to use Zoom and similar apps, I want to RDP to the remote computer and use Zoom, but I am NOT using a webcam or microphone connected to the local system (the console system I am running RDP from). The hardware is directly connected to the system I am RDP'ing to.

Previously I have learned that I need to run apps "as administrator" to access hardware like DVD-ROM drive for copying.

If I run the Zoom client "as administrator" the video shows up from my Logitech HD Pro Webcam C920. The Audio is routed back to my console system fine and I hear everything. BUT the microphone still doesn't show up.

If I go into Device Manager I see:

HD Pro Webcam C920

Plantronics BT600

Realtek High Definition Audio

Yeti Stereo Microphone

Yet when I open Control Panel > Sound > Recording it says "No audio devices are installed".

In the settings for Zoom it sees and I can configure the video camera and see myself in the video window. I can test the audio that is coming out of the speakers connected to the local console system fine. But as far as Zoom is concerned there is NO microphone hardware connected when I actually have multiple USB microphone devices physically connected to the remote system.

Please don't tell me about RDP settings to pipe USB devices connected to my console system to the remote system. That's not what I'm trying to do, and that seems to be all the google search results. I have the hardware directly connected to the remote system because when I use those devices connected to the local console system I can make it work but the video/mic aren't in sync and the Zoom participants and I aren't connecting in real time.

Any help getting this working greatly appreciated.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

0 Answers