question

MH-3174 avatar image
0 Votes"
MH-3174 asked SamWu-MSFT edited

Deployment IIS Manager Permission on FTP Server 2016

Dear Team
I want to deploy FTP server file access by IIS Manage users, i will not give users permission on management localuser for access.
I want to give folder access permission by IIS Manager users on FTP server 2016.

Note: I'm doing something wrong IIS users access permission. Please advice user permission. I have attached some doc for troubleshooting.

143629-2.jpg143665-3.jpg143675-5.jpg143676-4.jpg143654-e-log-1106.txt143549-redirection-config.txt
143674-1.jpg


windows-server-iis
2.jpg (50.4 KiB)
3.jpg (60.6 KiB)
5.jpg (17.1 KiB)
4.jpg (67.7 KiB)
1.jpg (53.3 KiB)
e-log-1106.txt (4.7 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MH-3174 avatar image
0 Votes"
MH-3174 answered

Dear tnmff@microsoft.com please advice about issue.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SamWu-MSFT avatar image
0 Votes"
SamWu-MSFT answered

@MH-3174

There might be a few reasons for running into this error. Here are the most common root causes and their solutions:

  1. The user may not be have access to the home directory. Go to “IIS > FTP site > FTP User Isolation”. Select the directory that your users can access. More information about User Isolation settings

  2. IIS may not be configured to use passive mode FTP. There are two types of FTP connections: Active mode and passive mode. In active mode, the client opens a port. The server connects to this port for transferring data. In passive mode, the server opens a port. The client connects to this port to transfer data. In order to use passive mode, enter a port range and IP address in "IIS > Server name > FTP Firewall Support" page.


If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MH-3174 avatar image
0 Votes"
MH-3174 answered SamWu-MSFT commented

Dear Samwu,

I tried looking at this document but failed again. How do I give access to screenshot users? please advice authorization roles users access grant .

145091-3-v1.jpg



3-v1.jpg (56.8 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@MH-3174 Sorry for not being able to answer your question in time, you can refer to this link to create a user for FTP access and give that FTP user FTP folder permissions. you also need to configure FTP authentication and FTP authorization rules to allow the user to get access to the FTP site. Creating an FTP user and managing user permissions.


0 Votes 0 ·
MH-3174 avatar image
0 Votes"
MH-3174 answered SamWu-MSFT edited

Dear MH-3174 ,
Thanks for advice
I want to IIS authenticate users permission in folder access on FTP server but I will not give access by local user and computer users.
What can I do to help more information? please advice.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@MH-3174

IIS authenticate users permission in folder

What are IIS authenticate users? Is it in AD or something else?
0 Votes 0 ·

Dear SamWu
I want to do by non AD users, I want to folder access by IIS management users.

Thanks

0 Votes 0 ·

@MH-3174 This link should solve your problem: configure-ftp-with-iis-manager-authentication-in-iis-7, but there is a problem, that is I am using iis 10(If you are using iis7, then you may not got this problem), even if I installed Management Service in Turn Windows features on/off, this feature is not available in my local iis, I can find it only in windows server. so, if you want to use it, then you need to install windows server.

0 Votes 0 ·