question

ForrestVodden-4834 avatar image
0 Votes"
ForrestVodden-4834 asked EchoDu-MSFT commented

External sharing links do not appear in Manage Access in SharePoint file library

Hello,

We have a SharePoint file library that we externally share files and folders from. We disallow anonymous sharing, and so specific emails must be provided when creating a SharePoint link. These links work as expected and the external users (guest or otherwise) are able to access the content. When it comes to revoke access, the Manage Access pane for the file/folder does not display these shared links. It lists all internal users and groups but says "There are no sharing links for this item". Accessing the Advanced Permissions page in the classic SharePoint interface doesn't seem to provide anymore information. Clicking the "Manage links to remove users" link results in a pop-up similar to the Manage Access pane and shows the same "There are no sharing links for this item".

How can I revoke access or audit what external users can access this link? Any help would be great.

Thanks!
143933-image.png


office-sharepoint-online
image.png (31.9 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ForrestVodden-4834 avatar image
0 Votes"
ForrestVodden-4834 answered

Further testing shows that this is specific to this SharePoint site (any library within it). What settings could cause this behavior?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

EchoDu-MSFT avatar image
0 Votes"
EchoDu-MSFT answered EchoDu-MSFT commented

Hello @ForrestVodden-4834 ,

Welcome to Q&A Forum!

Please follow the steps:

1.Sign in the Document library as a site admin

2.On the Manage Access panel, you can click Advanced link in the bottom right corner.

144006-1.jpg

3.Then, you will go to the Permissions page.

143975-2.jpg

3.Or, you can click the down arrow next to the user to remove or edit the external users’s permissions for the folder

144023-3.jpg

Thanks,
Echo Du
====================================
If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




1.jpg (55.4 KiB)
2.jpg (76.4 KiB)
3.jpg (26.9 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

External users I share with do not appear in that list. Additionally, the links I create to do not appear under the links section. Please see this quick screencast I created: https://www.screencast.com/t/16Kxs5GnN

0 Votes 0 ·

Hi @ForrestVodden-4834 ,

Will this problem occur when you Copy Link to internal users?

Thanks,
Echo Du

0 Votes 0 ·

Hi @ForrestVodden-4834 ,

Is there anything else I can help with regarding this issue?

You can comment us at any time and we will continue to follow up.

Thanks,
Echo Du

0 Votes 0 ·
Show more comments