question

WD-1178 avatar image
0 Votes"
WD-1178 asked WD-1178 commented

SSMS "The 'Microsoft.SqlServer.Management.SqlStudio.... package did not load correctly" and "Service 'Microsoft.SqlServer.Management.IRegistrationService' not found"

Hi there, I ran into a strange issue when I install SSMS v18.10 on my new work laptop (Win10 Pro Build 19042) with local Admin rights. I have tried both v18.10 and v18.9, uninstalled Extensions, etc. But none of them works. Can you please help? Thanks a lot.

The installation seems all good. But when launching SSMS, it prompts a warning message "The 'Microsoft.SqlServer.Management.SqlStudio.... package did not load correctly".

143967-image.png

After ignored this warning, when connection to our Azure SQL Database, it then prompts an error "Service 'Microsoft.SqlServer.Management.IRegistrationService' not found (Microsoft.SqlServer.Management.SDK.SqlStudio)"

143968-image.png

I also noticed under "Help" menu, there're two "About" items., one is "About SQL Server Management Studio", and the other is "About...". On my old work laptop, I only got one "About..." in my SSMS. When clicking "About...", I got the same warning message as when launching SSMS.

144021-image.png

When click ""About SQL Server Management Studio", I got below information.

144022-image.png


I have tried both v18.10 and v18.9, uninstalled Extensions, etc. But none of them works.


sql-server-general
image.png (27.5 KiB)
image.png (61.0 KiB)
image.png (99.4 KiB)
image.png (24.3 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

Cathyji-msft avatar image
0 Votes"
Cathyji-msft answered WD-1178 commented

Hi @WD-1178,

Did your VS is running? If so, please restart it as the error message mentioned.

Please repair the SSMS then run the SSMS as administrator. Disable Ransomware Protection in Windows.

If it is still not work, close all Visual Studio instances, then delete all files in the following folder:

Visual Studio 2013

%localappdata%\Microsoft\VisualStudio\12.0\ComponentModelCache

Visual Studio 2015

%localappdata%\Microsoft\VisualStudio\14.0\ComponentModelCache
Visual Studio 2017

%localappdata%\Microsoft\VisualStudio\15.0_xxxx\ComponentModelCache
Visual Studio 2019

%localappdata%\Microsoft\VisualStudio\16_xxxx\ComponentModelCache

Then run the SSMS again.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @Cathyji-msft, thanks for your response. I also suspected VS is the issue previously, so I already uninstalled my VS2017 and VS2019. These VS folders you mentioned were already gone. Unfortunately this didn't help.

I also tried Repair, and Run as Administrator, also didn't work.

I haven't tried the Disable-Ransomware-Protection. Let me give a try. Thanks.

0 Votes 0 ·

Hi @WD-1178,

If it is still not work, could you share us the screenshot about the list of the programs that you installed in your server. Control Panel\Programs\Programs and Features.

I want to check if any other programs effect the SSMS.

0 Votes 0 ·

Any update for this thread?

0 Votes 0 ·

Hi @Cathyji-msft , I had some new findings. I learned previously that SSMS writes some information to Documents folder. For some reason, my Documents folder on my new work laptops points to a read-only network location. What's more interesting is that I can't change Location of Documents folder, even after I was given administrator rights. However I'm able to change it on my old work laptop, even without Admin rights. I'm working with our IT to look at it now. Thanks.

0 Votes 0 ·