question

RiteshSharma-3070 avatar image
0 Votes"
RiteshSharma-3070 asked Crystal-MSFT commented

Enroll only in device managment Windows 10

Hi, I tried to manually enroll one windows 10 device to MDM using Enroll only in device management option. The device is already part of Azure Active Directory. Everything is working fine like auto installation of win32 application, configuration profile deployed successfully except win32 Apps are not showing in company portal under feature apps on that device. Which we configure to display in Company portal. It is displaying on other devices, which are auto enrolled to MDM. Please help to know, what could be the reason.

mem-intune-enrollment
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

yannara avatar image
0 Votes"
yannara answered RiteshSharma-3070 commented

To show apps in Company Portal, I also add available deployment to all users (or any user group) next to required deployment to devices.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for your reply!

0 Votes 0 ·
Crystal-MSFT avatar image
0 Votes"
Crystal-MSFT answered Crystal-MSFT commented

@RiteshSharma-3070, From your description, it seems one device which is manually enrolled to Intune is unable to see apps under company portal.

Based as i know, for the app deployed as required app, it is not shown in company portal. Given the situation, please ensure the app is deployed with Available intent and that the user is accessing the Company Portal with the device type supported by the app. here is a link for the reference:
https://docs.microsoft.com/en-us/troubleshoot/mem/intune/troubleshoot-app-install#user-group-targeted-app-installation-does-not-reach-device

However, if the issue is still there, please collect the following information to clarify:
1. Is the app deploy with required or available? Was it assigned to user group or device group?
2. What is the Azure AD join type of one working device and one not working device? Is there any other difference between the two devices records in Azure AD and Intune?
3. What is the windows version of the not working device?

Please try the above suggestion and if there's any update, feel free to let us know.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.


Thank you Crystal for your reply and link. It is not helpful.

Yes, device is manually enrolled and app which are not showing on Company Portal assigned as available for enrolled devices. Which is showing in company portal for the devices. Which are auto enroll to MDM (Intune).

Is the app deploy with required or available? Was it assigned to user group or device group?

Deploy with available and assigned to user group.

What is the Azure AD join type of one working device and one not working device? Is there any other difference between the two devices records in Azure AD and Intune?

Yes, there is difference, for the device its not showing. its already joined to Azure AD and manually enrolled device to Intune using option Enroll only device in MDM under Access work or school. App configured using Required is deploying without any issue only available apps are not showing in Company Portal. However, everything working fine with auto enrolled devices.

What is the windows version of the not working device?

Windows 10 21H1

We have actually more than 200 machines already joined to Azure AD. Which we are looking to enrolled to Intune. Any suggestion will be appreciated.

0 Votes 0 ·

@RiteshSharma-3070, Thanks for the reply. Based on my test, I find the device I enrolled with "Enroll only in device management" in my lab can get the available win32 app in company portal after wait for some time.
144340-image.png
144441-image.png
144442-image.png
Here, we suggest to go to Settings->Accounts-Access work or school, find the account, choose info and click Sync. wait it to be finished and then restart the computer to see if we can get the app. Meanwhile, we can check if the Microsoft Intune management extension is installed and if the service is running.


0 Votes 0 ·
image.png (18.1 KiB)
image.png (46.4 KiB)
image.png (16.5 KiB)

@RiteshSharma-3070, How's everything going? Is the issue resolved now? If there's any update, feel free to let us know.

0 Votes 0 ·